Snapshot with Title shortcut in Mojave

I can’t see another thread about this but if there is one, please forgive me.

I just updated to Mojave and it’s already driving me absolutely nuts. :unamused:

So I used to use the Snapshot with Title shortcut (up arrow+command+5) dozens of times a day, every time I finished drafting/updating a scene. Now of course, because that’s Apple’s fancy new method of taking a screenshot, that combination of keys has been hijacked and it simply opens the fancy new screenshot window.

Is there a workaround for this? Or something that could be changed in a future update to Scrivener?

Yes to both of your questions. :slight_smile: The shortcut will be moved to another sequence of modifiers in the 3.1 update (currently in beta), since we can’t do anything about which shortcuts Apple decides to take over.

In the meanwhile, you can switch off or move their shortcut, in the System Preferences: Keyboard: Shortcuts pane, under the “Screenshots” category. Personally I just unchecked their shortcut and then set the Scrivener beta back to the way it was before the change. I have no desire to train my fingers to use a new shortcut for this feature after a dozen years of using it this way. :slight_smile:

Ah, brilliant!! Thank you so much! And exactly that: my fingers have been trained :smiley:

I swear, I’ve learned more about how to use my Mac from Scrivener and these forums than I ever would’ve otherwise. Thanks so much.

I see the keyboard shortcut for snapshot with title has been changed as promised, to ctrl-alt-command-5. Sadly though, when I press these nothing happens. Is this a known issue or am I somehow goofing this up?

Seems to be working fine over here for me. Have you checked the menu to make sure the function is indeed available for the current selection? The second thing I would check, if you’ve created a custom shortcut, is the precise menu title. There are two of them depending on whether there is a singular or plural document selection:

  • Take Snapshot with Title
  • Take Titled Snapshots of Selected Documents

To do a full override you need to assign the same shortcut to both commands. They won’t conflict because only one of these will ever be available.

Thanks for the reply. I was trying everything last night, and knew the function actually worked via the menu, etc. What I didn’t try was closing the app and reopening. :neutral_face: shakes head

Working just fine now!

Actually, I take that back. It was working fine yesterday, on Project A. Today, it’s not working on Project B. So obviously with a few seconds of experimentation, it turns out that the snapshot with title keyboard shortcut works fine on Project A, but on Project B, it does the following:

If the cursor happens to be on a blank line in the editor, that combo of keys inserts a new blank line. If the cursor is on a line containing text, it converts that entire paragraph to the formatting for “Heading 2.”

I swear, I have the weirdest problems in Scrivener.

If, in Project B, I choose snapshot with title from the menu, it works fine. I’ve tried restarting Scrivener several times but it’s not helping.

Worth noting that the keyboard shortcut for Heading 2 is actually alt-cmd-5, and this is not what I’m hitting in Project B. I’m pressing the keys exactly as I am with Project A. When I do try that shortcut, it does change the font to Heading 2, but a larger size… when doing the snapshot shortcut, it shrinks the font by 3 points.

Agh!!

Any ideas? Why would this shortcut work in one project but not the other? Clearly I must have some setting on that’s causing the problem but I can’t figure it out.

  • Okay. So I discovered that I had no saved styles in Project A. I have them in all my other projects (6!) so I was surprised to realise I’d never imported them to A. After deleting all styles in Project B, I can now use ctrl-alt-cmd-5 to take snapshots with title.

I promise I was NOT hitting the shortcut for Heading 2, I tried it about 20x in each window, hitting the combo the exact same way, but for whatever reason Scrivener thought I was trying to change the style I guess. Very odd! Sorry for spamming with all these issues but I guess I’ve sorted it now.

Hmm, yes it looks like for some reason the style shortcut is “covering” the other shortcut—how that is even possible I don’t know, as the Ctrl key should not be simply outright ignored like that.

At any rate, you definitely do not need to delete all of your styles. You do not even have to delete the style that was assigned to ⌥⌘5, you can just open the Style panel, right-click on it, and use the “Change Keyboard Shortcut” contextual menu to either remove the assignment or change it to something other than 5.

Until this is fixed, just avoid 5 for your styles.

I had the exact same conflict with the keyboard shortcut for Style 5.