SOLVED: phonon errors on 64-bit Ubuntu 10.10

Edited 2011/02/23 : (Now using the 1.6 beta.) It looks as though the errors were related to manual changes I made to my system that broke my lib32. Or as we said when I was in the Army, it was, an operator headspace issue–As in there was too much empty space in the operator’s head.
:blush:

[i]OUTDATED EDIT: Not only do these phonon errors show whenever I open a project, but they seem to relate to another bug I was going to report.

Running Ubuntu 10.10 Maverick 64bit and Scrivener for Linux 1.5 beta 7.

In maximized window moden (not full-screen, just maximized window), especially after switching back and forth between other applications, but also frequently when opening a project in maximized window mode, the cursor selects something other than what I click on, and more phonon errors are simultaneously generated in the terminal. For example, I may click on a scene in the binder, but whatever is two or three lines above it is what is actually selected. If I click on the menubar it will react as though I had clicked on whatever is behind Scrivener. Un-maximizing makes this go away for a while, but eventually it begins again. More details as I experiment to see if I can find a more reliable way to reproduce.[/i]

Although Scrivener launches (albeit only from the CLI or a launcher that invokes the CLI) and runs, upon opening a project I get approximately one cubic ton of phonon errors. This does not seem to affect usability for text operations (see the edit above, as this has changed) , and I’ll have to put it through its paces to see if it affects anything else obvious, BUT… I figure that a buffer screen full of errors is probably a Bad Thing just on principle.

Oh, and I have all the listed *nix backends installed. Does the Windows version have phonon making calls to Quicktime, perhaps?

According to Wikipedia (en.wikipedia.org/wiki/Phonon_%28KDE%29):

  • Supported backends on most Unix-like systems are xine, GStreamer, VLC and MPlayer.[7]
  • Supported backends under Windows include DirectShow, VLC and MPlayer.
  • The backend supported under Mac OS X is QuickTime.

Here’s as many lines of the error I could capture:
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::VideoWidget ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::VideoWidget ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

Just a thought… you have gstreamer installed? (which is the required linux backend)

Yup. The Good, Bad, and Ugly sets.

If I’m the only one reporting this, though, it must have something to do with my setup. Instead of Gnome’s default top and bottom panels, I run a panel down one side and have a collapsible one at the bottom. Think that could have something to do with the weirdness? I’ll restore the default panel settings and see, but would you agree that even if it works with default panel settings, it probably counts as a bug?

Come to think of it, one thing that happens when it starts acting up like that is that the title bar gets intermittently pushed up past the top of the screen, and selections are offset by about the same amount of space as that.
EDIT: Does the same thing when I restore the panels to default settings and relaunch Scrivener. My screen resolution is 1280x800, in case that information helps.

Have you tried to hide the Inspector and resize the window? If the problem with the cursor persist, I have no other idea.

Thanks! Sorry to have brought this up if it’s a known bug already. And yep, everything’s fine when I hide the inspector. I do still get the same phonon backend errors in the terminal when opening a project, though.

I wonder if any of the following might be relevant:
I’m using ALSA instead of PulseAudio, and in addition to the Ubuntu restricted extras and the complete Good, Bad, and Ugly GStreamer sets, I have some codecs from the Medibuntu repositories that probably replaced some of them.

I have a few other tasks I need to accomplish first, but if others aren’t getting these same errors, I could do a virgin install of Maverick 64-bit on a VM with nothing but Scrivener, GStreamer, and the 32-bit aspell libraries, and if I don’t get those errors, start adding things until I do. Would that be helpful?

Sorry for the double-post. I installed the same beta (1.5 beta 7) on a VM, also running Ubuntu Maverick 10.10 with restricted extras installed (which includes the good, bad, and ugly Gstreamer sets) and nothing else, and still get a buffer-full of the same phonon errors. Again, though, all the word processing and organization functions seem to work just fine, though.

Could it be that Scrivener wants 32-bit GSreamer in much the same way that it wants 32-bit spell-check libraries? That would seem to make sense. I also seem to remember someone saying that Scrivener uses a customized version of qt4; is that correct?

I’m not as knowledgeable as I’d like to be about some of this, so for now, I’ll dig around a bit to find out if I can install 32-bit GStreamer without borking anything on a 64-bit system. Can’t see why I shouldn’t be able to, but I have a sneaking suspicion that the easy way may require adding the Medibuntu repositories. (Already enabled on my regular install, of course–just not on the VM I’m using to test things.)

Thanks for all your help so far!

Just launched it from the terminal

WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ). WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

I use Alsa. I have installed gstreamer0.10-alsa gstreamer0.10-fluendo-mp3 gstreamer0.10-nice gstreamer0.10-plugins-bad gstreamer0.10-plugins-base gstreamer0.10-plugins-good.

Yes, Scrivener uses a customized version of Qt4.

You can force-install 32bit, but gstreamer is not in medibuntu. Haven’t used ubuntu since hardy, but I believe now it has a repository with all problematic packages like the ones once hosted by medibuntu.

Here’s a shot of the Phonon stuff I have installed, including an inset of the metapackage description that says it includes the GStreamer backend. I could simply go on an installing spree, but I figured I’d see if anyone here had input first. Could this be something to do with qt bindings? If so, which ones? Or should I just go trial-and error.

And speaking of errors… Yeah, still getting all the sames ones as listed above. As I said, though, Scrivener has been quite usable for my purposes, even with the errors.

Thanks for the help so far with this!