Solved: Update Nano Word Count wants to update to Zero words

image

I’m not inclined to press that Update Word Count button. :smiley:
I logged out and logged in again, but get the same problem.

What may cause this? Is the interface down? A service disconnected?
Is it a temporary hick-up or persistent issue?
Is this an issue at nanowrimo.org or in Scrivener?
Maybe something changed at nanowrimo.org?

Updating Word Count via nanowrimo.org for now.
After a few strange behaviors from the site that worked…
Scrivener picks up the correct updated Word Count.

The NaNo site had a brief outage yesterday. I had writing done and a new word count, but it didn’t take for a few hours. It seems to be working better today (actually, later in the evening yesterday). It should be working now.

It’s still saying updating to zero, so I’m still not inclined to take a leap of faith.
Anyone familiar with the code who can explain why there’s a zero there?

Sorry, I misunderstood. That doesn’t sound right. The NaNo API service was down for a moment. My Scrivener was saying that it had words to update, it just never did while the API was down. There is another one or two threads here asking about the Scrivener side with similar reports like yours. I’m not certain why it would do that, so I can only guess what might be going on.

Am I the only one who’s experiecing this issue? Then I’ll have to look for other solutions…

image

Solution: to proof the point of being able to compile a manuscript in a different order than the Binder order, I created a Collection, messed up the order and compiled a Word document. That proved to be working and I deleted the Collection.
Today, curious to know how many words I’d added reading and updating earlier scenes, I choose Project > Statistics and got a Word Count of Zero.
The Compile for: drop-down list in the Compile Overview window still had the filter for the Collection selected, but I had deleted the Collection itself.
When I set the Compile for: drop-down list back to my Manuscript folder and Saved the Compile settings, the Word Count was accurate. Updating the Nano Word Count showed the correct amount of words again and the update worked as expected.

2 Likes