Some bugs when compiling

First, I tryed to do the following:
Create draft for poems so that every poem looks like this

Title1

Text1
Text1
Text1

Date of creation1

Title2

Text2
Text2
Text2

Date of creation2

So,

  1. I created Custom Metadata with DateOfCreation
  2. I created some poems in different documents with different titles
  3. I started compiling
  4. In Formatting I pressed Title Settings…
  5. I defined <$title> in TitlePrefixAndSuffix/Prefix
  6. I defined <$custom:DateOfCreation> in TitlePrefixAndSuffix/Suffix

Then I compiled and got strange result:

<$title> - 1 November 2003
Text1

<$title> - 2 November 2003
Text2

I think the bugs are

  1. <$title> does not work in Prefix
  2. DateOfCreation appeared in Prefix instead of Suffix

No, placeholders aren’t supported in the title/prefix/suffix field. Although <$title> actually is allowed - it’s the only one that’s allowed. But I only added that a few days ago, so please download the regular version instead of the NaNo version.

I can’t see anything wrong with where the date of creation is appearing - it’s appearing in the title suffix (obviously being a title suffix, it goes after the title, which it does in your example).

Best,
Keith

Probably You can recommend me something in my situation…

Sometimes I need to print poems with their creation date (in the end of each poem) and sometimes without creation date. Can I do this automatically with Scrivener?

Two possibilities spring to mind:

  1. Use Replacements in the Compile options. So, after your poem, put something like “{creation-date}”. Then, in the “Replacements” pane of the Compile options, have “{create-date}” replaced with “<$date>” when you want the date inserted, or with nothing when you don’t (you could even set up two compile presets, one for with dates and one for without).

  2. Place the date in the document notes and have the notes included in the compile, and placed after the text.

All the best,
Keith