Some kind of conflict with OSX Mail

Hi,

There seems to be some kind of conflict between Scrivener and OSX Mail. When I try to run both at the same time, Mail does not work properly. It hangs up, unable to load messages, and if I try to quit out of it, it simply stays in hang-up mode and I have to force-quit. I’m running Yosemite 10.10.3, and Mail 8.2, and most up-to-date Scrivener. There doesn’t seem to be any issue in the opposite direction that I can see—Scrivener seems to work fine.

I can’t think of any feature of Scrivener’s that would cause this. You could try disabling its Services from the System Preferences, “Keyboard” pane, under Shortcuts. These really shouldn’t be doing anything unless you actually use them though.

Just to get the obvious out of the way, have you rebooted recently? I’d also do some basic system maintenance. Use Disk Utility, make sure there is enough free space, that sort of thing.

It is very strange, whatever is going on.

Does Mail hang like that when Scrivener is not running?

I run both Scrivener and Mail simultaneously without any problems. Also have Messages, Firefox, Evernote, Terminal (with multiple windows), and MacVim open all the time. Occasionally running Scribus, Inkscape, and various other document processing applications. Never seen Mail or Scrivener hang because of other applications. Have seen them respond slowly when doing their own thing—like retrieving email from my mail server over a WiFi rather than hard-wire link.

Hi, thanks.

Yes, I’ve done all kinds of maintenance, repairing permissions, lots of free space, etc. this has been an ongoing problem with mail that I’ve been trying to isolate for a while now, and it was only recently that I realized the one common factor for when mail hangs up is that scrivener is running when it happens. It is very weird. If I quit scrivener, mail runs fine. So to get around it now I just try to make sure not to run them at the same time. I also am able to run lots of other apps at once with mail and scrivener with no problem, so it seems to be these two specific ones.

Long shot, but have you tried using Mailbox > Rebuild in Mail for your inbox, sent items, trash, drafts, archive?

You could also try…

  1. Repairing and reindexing the Mail app:
    osxdaily.com/2013/08/01/rebuild- … -mac-os-x/

  2. Deleting Scrivener, rebooting, downloading a clean copy, and then reinstalling:
    literatureandlatte.com/download_mac.php