Sometimes Wider Space After Period?

I can’t figure out why the space after the period after “breaths” is wider than other spaces:

SpaceAfterPeriod.jpg

I turned on Show Invisibles to confirm that it’s a single space.

Are you using full justification by any chance? The space between sentences is often one of the first places a justification algorithm will use, as the eye doesn’t notice it as much as variable spacing between words.

No. I suspected that, but that’s not it:

I’d double-check to make sure it’s a normal space. Unicode has a bunch of different space widths:

  1. Select the character with Shift-LeftArrow from the “S”, and copy it.
  2. Use the Edit ▸ Emoji & Symbols… menu command.
  3. If necessary, click the icon in the upper right corner of the palette to get out of emoji mode.
  4. Paste the character into the search field, surrounded by quotes (shouldn’t ordinarily be necessary to quote a character, but when searching for spaces I find that forces the search engine to include the space in the search).

The space character itself should be between the two quote characters in the results area. If you click into the area between them, it should highlight, with information on the character in the right sidebar. Here for example is an “em space”:

[size=80][/size]

What you want to see of course is “SPACE”, U+0020.

Did you try Edit, Text Tidying, Replace multiple spaces with single space?

I typed a “. S” somewhere else and copied and pasted it in, and it’s fine. I’m a little rushed now, but I’ll look into this another time. Thanks for your help!

Okay, happened again. I did what you suggested, Amber, but it seems to be just a normal space:

If I delete it and press the spacebar, it is wide again, but if I copy a space from another location and paste it in, then it is the normal space.

When I c ompile to a PDF or to a MOBI, the space is normal in appearance.

That’s not showing “SPACE”, U+0020, as Ioa mentioned.

If you click on the gear icon and then add Unicode as a category, does the character get confirmed as U+0020?

You mentioned ProWritingAid in another thread. Has PWA had access to the text?

Slàinte mhòr.

I think even without the extra information provided, it is still a regular space. It doesn’t display the code without the Unicode table in use, but it really shouldn’t be conflating the names of different characters. If it is a different kind of space, it would say so instead of “SPACE”. Maybe it’s worth a double-check though.

The only other thing I can think of is font related stuff—it could be the extra width is a scripted function of the font, similar to how ligatures work. I tried to find the same font (STIXGeneral?), and had a look at its typography features, but couldn’t reproduce the look. In case you’re using a different variant with more features, here is how to access typographic features on a Mac:

  1. Use the Format ▸ Font ▸ Show Fonts command. Place the cursor within the paragraph for the font you want to check (not the palette tracks the font under the cursor).
  2. Click the gear dropdown in the top left corner.
  3. Select the “Typography…” option.

I’d select the affected area and go through, experimenting with any options that look pertinent.