Space after Titles in Scrivenings / Numbering of documents

I am a big fan of the Scrivenings mode and recently found out the
Format --> Options --> “Show Titles in Scrivenings”
option, which makes it all the better, especially since I can also control the Font used for displaying them in the prefs.

The only thing that still bothers my eye is that there is no spacing between the title and the first paragraph.
I like to write with ample line and paragraph spacing, so it looks kind of awkward to have the section title glued together with the first line of the text. Is there a way to change that?

Another not really related question:
When syncing to an external folder, I can
“Prefix file names with numbers”
Is there a way to have the numbers respect the hierarchy of documents?
So they don’t just get numbered 1 Some title, 2 Some subheading 3 Some subheading,… etc.
but rather 1 Some title, 1.1 Some subheading, 1.2 Some subheading, 2 Some title, 2.1. Some subheading … etc.

I’ve used both these options for a number of years, and to the best of my knowledge, the answers are “no” and “no”. I find that underlining the scrivening titles helps me with visual separation but that’s the best I know of.

As for the numbering of external sync files, I believe the major intent is to provide a “binder” ordering for external editors. You’re right that it’s not helpful in distinguishing hierarchy. I’ve taken to putting that info into my titles but then, I don’t use those titles in compile.

I’ll be interested to see if anyone else has better ideas!

I use “paragraph spacing…before” on the body text to create a gap below scrivenings titles.

Fudge, perhaps, but it works.

Yes, paragraph spacing before was the only solution I could think of. Will use for now.

Oh well, I guess then I should submit both of these to the wish list …

(speaking of which, is it preferred to open one thread per “wish” or is it ok to put several suggestions into the same post?)