Space between lines (not at the end of a paragraph

One line in my document has an extra large space. I have the whole document set to double spacing and I checked the "other drop down menu and all of the options are set to zero. I can’t eliminate this space for anything. Please help. I am including a screenshot.

This forum is for giving tips, not for asking for help! Anyway …

https://forum.literatureandlatte.com/t/extra-line-space-not-after-a-paragraph/93985/1

No need to repeat yourself!

Thanks!