Speech double and unstoppable- Mac

Mac OS 10.14.6 Sc version 3.15

  1. Open Mac Preferences/Assessability, Click Speech. Check “Speak selected text when the key is pressed”
  2. In Scrivner doc select text. Press keys selected above. Speech will start.
  3. Click text outside of the previously selected text. Speech will continue.
  4. Go to Scrivner Edit/Speech. Stop Speech is greyed out
  5. In Scrivner doc select a different text. Press keys to start speech as set in Assessability
  6. Both text areas will be spoken at the same time. Go to Mac Preferences/Assessability to uncheck box to stop.

I use the Mac speech rather than Scrivner as I can select the voice and control the speed. Scrivner is too fast and too robotic.

It may be a Mojave issue with the macOS Speech feature. Working in macOS 10.15.3, pressing the shortcut again stops the speech, even if you create a different selection first. Are you able to toggle speech with the shortcut if there’s no new selection? (Clearing the selection once speech has started doesn’t do it; that’s just the way the feature works, and is the same in TextEdit, for example.)