Spell check disabled for a project, help?

MacOS 3.2.2 - just checked for update, and it says I’m current
Everywhere in my current project, “Edit/Spelling and Grammer/Check document” now shows as disabled.
Opened a random old project, and “Edit/Spelling and Grammer/Check document” is enabled, works as expected.
I’ve tried opening/closing Scrivener, the project, etc. Did I somehow set some weird project-level setting I don’t know about? Couldn’t find any similar posts in the forum.

update: I tried it again using the shortcut key command-semi, and it found one questionable word, but wouldn’t keep going. then I opened the spelling panel, tried to do a grammar check, and that worked. then I toggled check grammar off, and tried to check spelling again, and was able to check the whole project.

it does feel to me like it might be a bug - maybe an unexpected interaction between auto-check states and maybe whether the spelling panel is up or not?

To be clear, are you actually toggling spelling while typing on and off with the menu command, or just looking at it and observing its current state? That is an action—and each individual project can have it turned on or off independently.

The semi-colon command works independently of whether all errors are underlined always.

The problem I’m having is that check document now is disabled when I have a folder that contains individual project files selected in the left navigation pane in scrivening view (spell check is enabled for the individual documents, so I CAN do them one at a time)

I’ve been playing around with trying to figure out how I’m getting into and out of this state (it’s intermittent) & I think it may be related to the grammar checkbox setting in the spelling pane

images to clarify: photos.app.goo.gl/WweAG2qKkKYCUKnD6

Hmm, that is not something I am seeing on my end—indeed the way Scrivenings mode works is that it is essentially a normal text editor. The stuff that makes it magic, working on multiple items at a time, kind of exists on top of that, using hidden markers that cannot be deleted. So there should fundamentally be no difference between that and a single item editor view.

One thing worth double-checking though is that you have the focus in the right pane. If you’re checking while the cursor is in the binder (where up/down arrow keys change what you are viewing) then there is no document to check, at least from the very literal way in which software works.

Oops, I thought I replied to this, but I guess not!
I don’t THINK it was an issue of having focus in the wrong place, because it was specific to just one project, but whatever was going on stopped about a week ago.