Spell check false negative?

With spell checking as I type enabled, a word that is spelled correctly is underlined. Except that the built-in dictionary recognizes the word too…

I’m not even sure how to reproduce this. I even triple checked paper and online dictionaries convinced my spelling still must be wrong… Screenshot attached includes the scrivener dictionary lookup.

[UPDATE] Meant to add - Version: 2.9.0.41 Beta (855326) 64-bit - 05 Mar 2020

Also double checked that this wasn’t a case of UK vs US usage (which happens far more frequently than I care to admit)(stupid differences)

The reason for the problem that you describe is that the Aspell spell checker dictionary is different from the WordNet dictionary. As you can see the WordNet dictionary is usually a superior one. We use predefined Aspose dictionaries from reliable sources, but it might be that they are not complete or need updates. Meanwhile you can add the missing words manually, or add them to your custom dictionary.

Ah! That makes sense, thank you for the quick reply!

At [url]https://forum.literatureandlatte.com/t/jh-dictionaries-portuguese/42169/6] are instructions for replacing your dictionaries, if you want further reading. This is not supported by L&L. I tried replacing the dictionary and it worked. This still works. Every update I replace the dictionary again from a backup.

I went to the SCOWL site at http://app.aspell.net/create. I only used American spelling, but included level 3 spelling variants, both special lists, and the “insane” size. ~350k lines in the word list.

Hi, I had the same problem of getting US spellings (esp ize not ise). I followed the instructions on downloading an new dictionary. I hit 2 issues:

  1. There was no Hunspell Directory / only an Aspell one.
  2. I created the Directory and copied to the directory
  3. Scrivener still uses US spelling. I suspect it is using the Aspell.
  4. I looked in the Dic file and the ise spellings are there.

Please can someone say how to get back to UK spelling.

thanks.

Scrivener v3 uses Hunspell, Scrivener v1.9 uses Aspell. Mos likely you have followed v1.9 instructions, which do not work for v3 Beta. Check the forum, some users reported URLs with useful Hunspell dictionaries.