Spell check issues

I feel silly asking this. For some reason, Scrivener stopped spell checking as I type. I have checked settings on my iMac and on the software over and over as I have worked. it will check spelling if I click on “check document” but it will no longer check as I type. It’s driving me crazy as I like to correct as I go. Here are the things I have done.

Check the universal settings on the iMac.
Check the program settings on the software.
Save, backup, exit the program and restart.

And all manner of variation on this. I have written thousands of words using this program and it’s worked just fine. I stopped about a couple months ago. Any ideas?

As always, have proper backups/clones.

If it’s just Scrivener, try reinstalling it.

Scrivener uses the Mac OS’s spellchecker. Some generic Mac troubleshooting steps to try –

If you’re using any active, third-party security apps, at least temporarily disable/uninstall them using the vendor’s instructions; test.

SMC reset; test: support.apple.com/en-us/HT201295

Boot into Safe Mode, test, then boot normally; test: support.apple.com/en-us/HT201262

Create a temporary user account to test: support.apple.com/en-us/HT204443

Thanks, I will give these a shot in the morning.

Yep, a reinstall did the trick. Trees, forest, etc.