Spell check like Text Edit?

Is it possible to get Scrivener to spell-check interactively in he same way that TextEdit (and many other Apple apps) does it? I find that for typos, it’s much more intuitive that the default Scrivener method, which seems more like iOS.

Here’s an example of how TextEdit deals with spell-checking:

TextEditSpell

If there isn’t a setting to accomplish this, I’d like to request it as a feature in a future build of Scrivener. Using the current spell check system feels like I’ve changed OS, and not in a good way.

Edit → Spelling and Grammar → Check Spelling while Typing.

Thanks, but I already know how to activate it. I’m asking about changing its default behavior.

I’d like Scrivener’s interactive spell check to behave like TextEdit’s spell check.

Things I don’t like about Scrivener’s default spell checking behavior:

  • It sometimes suggests a replacement word with no user interaction;
  • If you type any key except ESC, it will substitute it’s suggestion – this often creates new errors;
  • To correct marked misspellings, you must select the entire word before right-clicking;
  • If you directly right-click or single-click followed by right-click, the spelling system won’t engage;
  • Scrivener’s spelling system misses words like “som”, because it is an obscure Khazikstani word. TextEdit marks it as a misspelling and suggests either “sum” or “some” as a correction.

If there’s no setting to change the spell check behavior to behave like TextEdit, then this is a feature request.

Do you have the Mac autocorrect feature turned on? (Apple → System Preferences → Keyboard → Text) Scrivener uses the same text system that TextEdit does, and should behave the same way if the settings are the same. In particular, suggesting or applying a replacement without user interaction is autocorrect behavior.

(Mac OS autocorrects are blue, rather than red, which is how you can differentiate between them and spellcheck corrections.)

Thanks for the suggestion and the additionla info.

I have autocorrect off in System Prefs. TextEdit’s corrections are underlined in red. Scrivener underlines in both blue and red.

Is there a way to get Scrivener to stop autocorrecting?

Scrivener → Preferences → Corrections. Uncheck “correct spelling errors as you type.”

If that doesn’t fix the issue, please open a support ticket, here: