Spell check not working in Lion?

Hello,
i’ve recently upgraded to lion and updated my scrivener to the newest version. But i found out that spellcheck is not working for me. i have looked at the preferences and made sure the ‘check spelling as you type in new projects’ box is checked. i cant find the setting anywhere else.

does ‘check spelling in new projects’ mean that the spelling in current projects will not be checked? how can i enable it again?btw i’m writing in english, and the project is created before osx lion came.

thanks in advance :slight_smile:

Hello,

Existing projects can turn on or off spell-checking independently via the Edit > Spelling and Grammar menu. Note that there does seem to be a bug in Lion whereby if you switch to page layout view and back, the red underlines no longer appear until you close and reopen the project (the same happens in TextEdit - it seems to be a Lion bug).

Hope that helps.

All the best,
Keith

thanks so much!

Spell check is not working for me in Lion either. I bought Scrivener 2.1 from the App store after I installed Lion. I have all the check boxes checked in the right places for the spelling defaults as well as for the project.

Switching Page Views or opening and closing the project has no effect. Spell checking does not happen.

Let me know how I can help track / report this issue.

I have the exact same problem in Lion and it is driving me nuts. I really miss not having my spelling and grammar checked in real-time.

Unfortunately this is almost certainly a Lion bug, because spell-checking is handled at the OS level, and there is no code in Scrivener that touches it besides turning it on or off. If you can find an exact reproduction case, though (I haven’t seen it myself), let me know so I can test and pass it on to Apple if it is indeed an OS X bug.

Thanks and all the best,
Keith

I’m having the same problem. It’s so frustrating, as I find this application wonderful otherwise. I have not experienced the problem in my other word processing applications.

Spell checking manually, clicking “next” through each word at a time, drives me mad, since I’m an academic and invariably have a ton of author names cited in my papers.

For those struggling this problem – I may have found a partial, work-around solution.

I believe all of my settings are set correctly. None of this helps. What does seem to work is entering the full-screen composition mode. Here, all of my red and green squiggles appear. When I return to normal view, they still don’t work. However, I suppose can manage in full-screen mode until Apple gets this resolved.

Can you please let me know under what circumstances they appear? Unfortunately Apple provide no way for developers to tell the spelling system to re-check text - it’s just an on/off thing - but if I can find the trigger I can at least look to see if there is a workaround.

(Incidentally, the OS X spelling check system will only be used in word processors that use the OS X text system - Bean, Nisus and TextEdit do, but Word, Mellel, OpenOffice and suchlike all use their own custom spell-checking engines.)

Thanks and all the best,
Keith

Hi Keith,

I’m not sure how much help I can be in this regard.

I’m new to Scrivener and Macs. I downloaded your application from the app store (on Lion) and then began moving parts of my dissertation in from Word.

I can’t remember if the squiggles worked when I started. I think they did; I think it would have immediately caught my eye if they did not. However, I can’t be sure.

I noticed the night of my first posting that it wasn’t recognizing my misspellings unless I highlighted a word specifically and spelled checked that word, or went through the entire manuscript word by word. After I did this, the squiggles would appear if I ignored the misspelling and went on to the next word.

But as I continued writing new text, it would continue to ignore (i.e., not squiggle) my misspelled words. And they remained unsquiggled until I did the manual spell check. I tried creating a new project and the squiggles did not work. I tried opening and closing my dissertation project and the squiggles still did not appear.

I’m pretty sure that my settings are correct.

If you want me to do anything on my end to help you troubleshoot let me know. It’s curious that the full-screen mode works fine. It’s the regular mode that has the problem.

Your application is wonderful, by the way. Having used it, I expect to be a life-long user.

Best,
John

Hi John,

Many thanks for the kind words; I’m glad you like Scrivener so far, aside from this one issue.

Just to double-check a couple of things:

  1. In affected projects, if you go to “Spelling and Grammar” in the Edit menu, is “Check Spelling while Typing” ticked? (If the squiggles are working in full screen, then it almost certainly is, but just to be sure…)

  2. Do you generally work in page view mode, or regular one-long-scrolling-text-area mode?

  3. If you go to Edit > Spelling and Grammar > Show Spelling and Grammar, what language is selected? If it’s “Automatic by Language”, could it be that you use a number of foreign words in your text? What happens if you set the language specifically? (Note that the language will always reset to the system default when you restart - that’s an OS X thing for which I don’t think there’s a solution - so if this does help then you will need to set the spelling language in the System Preferences.)

Thanks again and all the best,
Keith

1) In affected projects, if you go to “Spelling and Grammar” in the Edit menu, is “Check Spelling while Typing” ticked? (If the squiggles are working in full screen, then it almost certainly is, but just to be sure…)

Yep, this is clicked.

2) Do you generally work in page view mode, or regular one-long-scrolling-text-area mode?

I like working in page mode because I’m obsessive about knowing roughly how many pages I’ve written. However, I just tried changing it to one-long-scrolling-text-area mode and the problem persisted.

3) If you go to Edit > Spelling and Grammar > Show Spelling and Grammar, what language is selected? If it’s “Automatic by Language”, could it be that you use a number of foreign words in your text? What happens if you set the language specifically? (Note that the language will always reset to the system default when you restart - that’s an OS X thing for which I don’t think there’s a solution - so if this does help then you will need to set the spelling language in the System Preferences.)

It was set to Automatic by Language. You saying this is interesting because I noticed the problem immediately after writing several paragraphs about two forms of community defined by a famous German sociologist. The communities are gemeinshaft and gessellshaft. The words are German, and I was using them left and right.

It’s possible that the squiggles did not work before writing these paragraphs, but I noticed afterward. And I think I would have noticed pretty quickly.

In any case, I tried your recommendation of changing the setting to English and the problem persists. I even closed out of my project and Scrivener altogether. Perhaps it’s just a coincidence.

Something important that I just realized: I just closed out of my project and started a new one. The red squiggles work fine here in regular mode now. So, the problem seems to be linked to my bringing earlier project in from Word. I ultimately need to get it working on my dissertation project because, well, it will consume the next two years of my life. Perhaps if I start anew and copy everything in again I’ll have better luck. Do you have any recommendations for bringing everything safely into a new project without having this problem reoccur? Before I simply copy and pasted different chapters from Word into different “blocks” or sections in Scrivener, not knowing how better to go about getting everything in there.

Where the work comes from should make no difference - once you’ve imported work from Word, Scrivener has no idea where it came from; it is just an RTF document inside the package that gets loaded the same as any other, so this is likely to be a red herring. I think the fact that you have German words in there is more likely to be the culprit. “Automatic by language” tries to guess the language, and if you use more than one language in a document it may then interpret misspelled words as correct from some other language. Also, if you reset the language to English and then restarted to Scrivener, it will revert to Automatic by Language again because you have to set it at the system level - I’m not sure from your reply whether you tried that, but if not, go to your System Preferences, click on the “Language & Text” pane, and in the “Text” tab set the spelling language as appropriate. Then try restarting Scrivener and see if that makes any difference.

Thanks and all the best,
Keith

That did not work, unfortunately. And the “words” that it does not recognize are sometimes not words in any language (I hope not, anyway). As I experiment and try to get it to work, for example, I’ll type in “lksjdflkjsa” or something quickly to see if it gets underlined. Nothing gets underlined.

It does seem meaningful that the function works fine when I start a new project. I wonder if it could have anything to do with project size or some other variable, like hidden characters importing some how. Neither makes sense to me. But those and time elapsed (and perhaps the German words) are the only things that appear to have changed since I started this as a new project.

It would be nice to talk to the posters above to see what we all have in common. It doesn’t seem like too many people are experiencing this issue. I wonder what we were both doing or had just finished doing after it stopped.

I think what i may do today if I have time is 1) start a new project; 2) start bringing in pieces of my manuscript and 3) testing spelling functions after every copy and paste. This may help me isolate where things go wrong.

Happy to try any other recommendations you have.

John

UPDATE: Creating a new project and bringing in all of my documents seems to work, at least for the time being. The old project still does not show squigglies; the new project does. All of the settings seem to be the same. All I did was grab all of the text chunks from one project window and drag it into a new project in one fell swoop.

I can’t imagine this is particularly helpful from the standpoint of bug fixing… I’ll update this thread if anything changes.

Thanks,
John

Hi John,

Hmm, that is very odd. In that case, try this with the original project (the one that still doesn’t show squiggles):

  1. Go to the File menu.

  2. Hold down the Option key. You should now see that “Close Project” becomes “Close Project and Clear Interface Settings”.

  3. Click on “Close Project and Clear Interface Settings”.

  4. Reopen the project.

  5. Turn on spell-checking via the Edit menu if necessary (whether it’s on or off at this stage will depend on your preferences).

This will remove an internal settings file that remembers the interface state - no project data is removed, but the interface will be reset (using the default window size, everything in the binder collapsed, and so on).

Does spelling start working again now?

Thanks and all the best,
Keith

When I go to File and hold the option button the only thing that changes is that “Save” becomes “Save and Rebuild Search Indexes”. Close project does not show any additional text.

I’m new to Mac, so I could be making a mistake. But the fact that the “Save” changes after pressing the option key makes me think that I’m doing it correctly.

Perhaps this has something to do with the Lion update? Let me know if you can think of anything I might be doing wrong.

Have you updated to Scrivener 2.1 yet? You can check by using the “Check for Updates…” command in the main Scrivener menu. You should be seeing both the Save and Close actions get alternate commands when holding down the option key, but in 2.0.5 only the Save and Rebuild would show up.

Yes, I’m using 2.1 on Lion. I’m appending two screen shots: one shows my File menu after pressing “option”. The other shows my Scrivener version.

Ah, sorry, my mistake - that option isn’t available yet in the App Store version. In general the App Store version is identical to the one on our site, but in order to ensure Scrivener was on the App Store in time for Lion’s release, I had to submit it for review over a week before Lion was released; during the following week I then made some last minute tweaks to the version that went on the site. 2.1.1 will bring them back into line again. In the meantime, you can either download the latest beta ( https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1 ), which works regardless of whether you are a MAS customer or from our site (so long as you have run Scrivener at least once - although note that if you download it, you will want to delete it when 2.1.1 comes out in order to re-download from the MAS), or do the following, which does exactly the same thing:

  1. With Scrivener closed, in the Finder, ctrl-click on your .scriv project.

  2. Select “Show Package Contents”.

  3. in the Finder window that appears showing the internals of the .scriv file, drill down into the Settings folder.

  4. There you will find a ui.plist file - move it to the Trash (this is the only file in the project that it is safe to move to the Trash).

Now re-launch Scrivener and open the project.

Thanks and all the best,
Keith