Spell checker - don;t vs don't etc

Hi all,
I am aware that Scrivener uses the Mac’s built in dictionary, as opposed to MS Word which uses it’s own. That’s a shame because I have an unfortunate habit of typing a

;

instead of a

So can;t, don;t etc. always come up on spellchecks. MS Word is great though, it suggests can’t and don’t etc. Scrivener doesn’t, and despite investigation I cannot find a way to get it to do so.

Any ideas?
Cheers
Paul

Go to System → Preferences → Keyboard → Text. Enter “don;t” in the ‘Replace’ field and “don’t” in the ‘with’ field. Will work across all apps.

:wink:

Mark

1 Like

Worked a treat. It appears to be case sensitive, if anyone else picks this issue up.

Thanks Mark.

@xiamenese’s fix will propagate to all Apple devices on the same Apple ID, including iPad and iPhone.

1 Like

And to think I was about to suggest remapping the keyboard. :sweat_smile: Saved by the bell!

1 Like

Try just setting ;t to be replaced by 't, so that it works with any apostrophe-t contraction.

I just tested this, and it works, so you only need one entry for all such contractions.

4 Likes

Thanks everyone, sorted.