Spell checking issue.

I’ve found that in numerous occasions, scrivener stops underlining spelling errors. I have to go into tools-options-corrections and click the apply button to get them to show up. The thing is, the options are already set up “check spelling as you type” and so I shouldn’t have to do this. I’m not entirely certain why it’s happening, but it seems like a bug.

Thanks for the report. What dictionary language are you using? Does the check spelling while typing disable in both editor splits or just one, or only in specific documents? If you can find any particular trigger, that would help greatly in tracking this down. Has this only been occurring since upgrading to 1.7.1 or did you see it previously in 1.6.1 as well? What version of Windows are you using? We’ve just got one other report of this same issue, but so far no way of reproducing it. The more details you can provide, the better. Thank you!

I just got this, so I will probably spend weds day trying to take down how the bug occurs, but right now it seems to be intermittent rather than regular and seems to have been a result of the 1.71 upgrade.

As far as I can recall is can either occur upon starting scrivener or at intermittent points after starting it. Going to correction’s options menu and hitting “apply” seems to always fix it.

Another factor is that when the bug occurs, you can’t bring up alternate spellings of misspelled words by right clicking–I’ve tried that with knowingly misspelled words so it appears that it isn’t just a visual bug, but the entire subsystem is disabled.

I’ll try and get back with more, but I have a few midweek deadlines to get to.

Thank you!

I have also noticed this issue and only since upgrading. It almost always happens on start-up. As cgray77 said, it seems like the whole spell-check system is turned off even though it is checked in the options. Reapplying the option turns it back on again.

Windows XP
English (United Kingdom)

I noticed this today. I exited and restarted S and it was OK.

I’m also having this issue. Seems to be random. Running Scrivener on Windows 7 Pro 64-bit.

I have the same issue.

English (United Kingdom).

When the window is split, the spelling check is disabled in both documents. It does not happen in specific documents; as far as I can tell the whole Scrivener project is affected.

There is, as far as I’m aware of, no trigger, at least not manually from my side. In today’s occurrence of this bug, I was working on a document (split vertically with the same document in both windows) and spell check was working. Then I took a break, returned and continued working on the same document (without switching to another document or other Scrivener actions). I then noticed that the spell check was off.

Perhaps it is related to the automatic save, that occurs after x seconds of inactivity?

This behaviour started with version I’m absolutely sure of that, since I use Scrivener for a few hours every day (and make spell errors every day :slight_smile: ): if this bug occurred pre-1.7.1, I’d have noticed it before.

Windows 7 SP1 (64bit).

Today (7-7-14) the error occurred after creating a new document (single view).

I got the following error today on Scrivener (if this thread is still being monitored):


I’m mentioned it here because in this thread that error has been linked to spell checking issues.

Edit: After installing Scrivener 1.7.2, I still do not have that .dll file in my Scrivener folder. Where can I locate a safe version of that .dll?

Scrivener doesn’t use the QtSvg4 library indicated, so it isn’t included in the installation. It’s also not used by Aspell. I’ve attached a copy, but as I’m not sure what on your system is trying to access it (some plug-in that’s being called?) I don’t know if it will resolve the issue. I gather from your other post that Scrivener is running in spite of the message?
QtSvg4.zip (112 KB)

Thanks for everyone’s reports on this. We’ve found that opening the Compile dialog or Project Statistics will disable the spell check in the project. Opening Options and clicking OK will reset the spell check as you type and it seems to then persist through the remainder of the session, until the project is reopened.

I don’t have a Scrivener plugin, but the error message has not been triggered again in the last two weeks. Yes, in spite of the message Scrivener is running. :slight_smile:

Thanks for fixing this issue in 1.7.3. :slight_smile: