Spell checking with v3

I am not sure what is happening, but with version 2, words would automatically change or MacOS would show suggestions for autocompletion, but with v3, I am not seeing any of these events any longer. I have checked and made sure the settings are checked as necessary, but for some reason, nothing happens when working on a project upgraded from v2 to v3.

Regards

You have Suggest Completions as you type selected, but below that you also have In script mode only selected, so you won’t see suggestions unless you’re working in script mode.

Did I check that or is that on by default? I honestly do not remember?

I’m not sure. All I know is that it is a preference that needs to be checked/unchecked to work according to your needs.

So what about now? I started a simple sheet and tried to type a sentence and no corrections or suggestions popped up.

When I talk about suggestions, I mean this:
Screen Shot 2017-11-21 at 06.32.04.png

Thanks.

Has anything changed in your System Preferences? I think what you’re talking about is governed under the Keyboard -> Text preferences.

Nothing has changed in my System Preferences.

Your screenshot shows that you have it turned off completely.

You need to have just the top row (‘Suggest completions as you type’) ticked, but the other two (screenwriting and custom dictionaries) unticked.

Then make sure the Edit > Spelling and Grammar > Check Spelling while typing’ is ticked as well. (This is the way — cmd-\ — you turn it on and off temporarily, over and above the ‘default’ setting in Preferences.

With these options I get both the standard MacOS autocorrect and Scrivener’s suggestions.

HTH.

Yes, I missed that detail.

Not on computer right now, but when show suggestions box is checked, a drop down list of words appear. This never happened with v2. I will have a screenshot later.

Removed v3 version and reinstalled with new v3 and the spelling issues seem to have been corrected. Not sure what was happening, but all is well now.
thanks