Spell checking?

Is there any way to add words to the spelling dictionary so it’s identical to my Word dictionary, which has hundreds of words added?

Is there any way to set the spelling to UK English rather than American, so I don’t have to change every ize word to an ise word and every or word to an our word and every ter word to a tre word?

I’ve tried cmd-: to start the spell check, and it highlighted my main character’s name. Fine. But then I couldn’t see any way to add it. I tried control-clicking the word, and sure enough there was ‘Learn Spelling’, but this is a tiny bit clunky to do every time.

You need to use “Show spell checking” which should have come up with a window which (a) at the bottom has an option to change the dictionary to British English and (b) gives you a learn option. Are you sure you pressed Cmd-: or did you press Cmd-; which just gives you “Check document now” rather than the window?
This is part of the OS-X system and should be the same for virtually all apps … MSOffice being an exception, I presume.
:slight_smile:
Mark

You can change the spell checker to British English system wide via the system prefs.
Click International
click edit list button
Scroll down and find and check British English, click ok
over on the left hand side drag British English to the top of the list.
Reboot or log out and back in.

Perhaps I’m just slow on the uptake but it’s taken me three months to find that.

Cheers Mike

I pressed command and colon, not command and semi-colon.

Although the Edit menu in Scrivener lists command-: as invoking ‘Show spelling’, this keyboard shortcut doesn’t invoke that dialogue box for me, but only starts it checking spellings and stopping at ones it queries.

However, I can get the dialogue box by going through the menus; tiresome but doable.

Thanks for the tip on the System prefs; I’ve added British English and also Gaeilge, which will make quite a difference!

Three months!! Is that all :open_mouth:
Vic :blush:

Fecked around a bit and found that command-shift-colon brings up the dialogue. It doesn’t recognise words in Gaeilge, though, so I’m not sure that it’s using the system dictionary.

Oh, wait, though, it’s using British English rather than allowing me to set up a custom dictionary. Hmm.

Apparently the next version of Scrivener will import Word documents correctly even if they don’t have .doc (and hopefully .docx?) extensions; the current version imports them with various gobbledegook, and doesn’t seem to recognise apostrophes - the spellcheck keeps asking me whether I want to save ll and nt in she’ll and isn’t.

Yes, it’s a problem with the system dictionary … I guess you’ll need to teach it those. I have never been bothered. There is an alternative dictionary system called cocoAspell which I used under 10.4 I don’t know if it works under 10.5 as I haven’t bothered to try. That might do better on the abbreviated forms. I notice my spell-check is not picking them up here, so I guess I must have taught them to the spell checker, though I don’t remember doing so.

Mark

I posted something that is related to your question in this thread

This may help

Before doing this though change your dictionary to UK instead of US. WHen you “learn” a new word in the OSX dictionary it works in all applications that use the OSX spelling system

Having a lot of trouble with spellchecking:

  1. Most of the time the “Check Document Now” is ghosted out, no matter where I click in my document, or even on the root Manuscript folder. cmd-shift-: seems to invoke the dialog however.
  2. Sometimes the spell checking dialog comes up with nothing at all, and I know I have errors in my document.
  3. When it first found one of my character’s names, I clicked Learn, but then neither ignore or Find Next would progress, it would just stay on that name. When I quit spellcheck and started it again, it was ok.
  4. Even when spell checking is working (I do it from the root Manuscript folder) so as to check the entire m/s), when it finds an error it doesn’t show me in context. I am still seeing my corkboard. It refuses to jump to the place in the text where the error is.

The only way I can get spellchecking to work at all is if I manually go to every single scene, click on the first character and then spellcheck. I’m certain that is not the intent of “Check Document Now” :slight_smile:

This is Leopard 10.5.7

Help would be appreciated, thanks.

I’m sure someone more knowledgeable will come in and maybe correct me, but if you choose the draft or other top-level folder, you will get the corkboard, where the cards only hold the synopses, not the full text of each file. If you want to do the whole manuscript at one go, I should think you should select all the documents, maybe by choosing the top-level folder, then select “Edit Scrivenings”, which will run the documents together temporarily as if they were one, and then do the spell-check on that.

:slight_smile:

Mark

Edited to add “but” :slight_smile:

That was a good idea, and even better - it works. Thanks!