spellcheck menu option greyed out after update to 1.8.5

Hi all,

Today I logged into Scrivener for the first time in a couple of months, to be greeted with the update notification, which I did.

I’m happily typing away and go to spell check my short story. However, the menu option under Tools is greyed out. The two listed shortcuts (Ctl-Q and Ctl-G) don’t work. In fact, Ctl-Q turns the current paragraph into a block quote, while Ctl-G doesn’t do anything at all.

Interestingly, the spell check icon I added to my taskbar somewhere along the way does work when you click on it.

Is there something I need to do to get the menu option working, or is this a bug of some sort?

The touchpad on my keyboard is going wonky, so I generally have to turn it off when I’m typing a lot of stuff, or it will cause all sorts of issues.



The shortcut is a combo shortcut, not two separate options. So you would hold Ctrl, then press G, then Q, then release Ctrl.

Are you accessing the menu via the Alt key? I see there is a bug where it seems to be shifting focus, so the command is disabled when using the keyboard to access it. Using the mouse should work, so long as the focus remains in the editor, but I see you’re having trouble with the touchpad so maybe that’s not an option. In that case, teh keyboard shortcut above is best. You can also provide a different shortcut via the Keyboard tab in Tools > Options.

Thanks for the response. I guess I was reading the keystrokes backwards, which is why the Ctl-Q was immediately making the block quote. That comma, followed by Ctl again, is what confused me. Definitely think I’ll be reassigning a different keystroke to that one. :slight_smile: