Spellcheck on Mac 10.9.4

Hi all I am new to the IMac and have treated myself to Scrivener for my birthday but am having issues with spellcheck. I know some people hate the red squiggly lines under misspelt words but I heavily rely on this feature and can’t work out how to turn it on. I have gone to Edit-spelling and Grammar and have both “check spelling while typing” and “check grammar with spelling” checked but there are no red lines under my misspelt words. am I doing somethang wrong. (I spelt that wrong on purpose. That’s how much I love the red lines) I think my Mac version is a Maverick if that helps.

Check this thread, it might address what you are seeing.

Thanks I checked this out and tried all it advised but it hasn’t changed a thing. If I send an email on the imac and misspell something the red lines appear so it’s not an apple issue. After re setting the system I now have red lines in compose full screen mode which I didn’t have before so I guess that is better than nothing. :smiley: