Spellcheck, smart quotes, & em-dash autocorrections won't work

Thanks in advance for any help! In the main editor, some of the autocorrections are not working. Suddenly,
(1) no words are being underlined with red,
(2) smart quotes no longer work,
(3) and em-dash (from --) corrections are no longer being made.
I have tried unchecking all the boxes in Preferences>Corrections, rechecking them, restarting Scrivener all in different orders. No luck. :frowning: Any suggestions?

Thanks again!

P.S. I am aware of Formatting>Convert to get smart quotes, but I want the auto-corrections.

I’ve found this a persistent but unpredictable bug that began with Sierra. The only solution I’ve found is to close Scrivener, and when it’s finished writing the backup file, to restart the system. It’s 100% effective, at least for me.

So just as Mountain Lion fixed Lion’s many bugs, El Capitan did a good job on Yosemite, can we now expect High Sierra to fix Sierra’s maddening properties? (Don’t look at me - I’m still using Mavericks…)

I had similar problem but with a twist. When I opened up a new project curley quotes would not work but at the same time would work in a old project - see screen shot (old project at top, new project at bottom). But when I restarted the new project curley quotes started to work. Strange.

My episodic hauntings also include the loss of curly quotes and an inability for two hyphens to automatically turn themselves into an em dash. I’m hoping this’ll get fixed in Scriv3.0. As it sits, it’s annoying but manageable, like dyspepsia

I use Scrivener 3.1.1 but smart quotes don’t work properly. I use mac and smart quotes work fine in all other applications, except Scrivener. I know it’s a scrivener problem because smart quotes work in the compose mode in Scrivener. But I do not always use compose mode. Thus I find this inconvenient as I have to manually change straight quotes to curly quotes.

For each project, is Edit > Substitutions > Smart Quotes turned on, i.e. does the setting have a tick indicating that Smart Quotes are active?

Two other ideas:

  1. Load the manuscript in scrivenings and then choose:
    Edit > Transformations > Convert Quotes to Smart Quotes

2.Type the marks you need:

Left single quotation mark: OPT ]

Right single quotation mark / apostrophe: OPT SHIFT ]

Left double quotation mark: OPT [

Right double quotation mark: OPT SHIFT [

Slàinte mhòr.

Has anyone found out how to fix the spellcheck, I have the latest MacOS and the latest Scrivener but it doesn’t underline or suggest any words. I have to go through slowly to make sure I haven’t missed anything. And for me that is slightly harder to do.

Is the setting below switched on for each project?

Edit > Spelling and Grammar > Check Spelling While Typing

Slàinte mhòr.

Thank you that fixed the issue for me. Bit odd all my scriv 2 files when converted stayed the same figured it was to do with scriv 3 files.

Thanks for your reply. Smart quotes was already on. But I toggled it and then restarted scrivener. It worked. Smart quotes working now.