Spellcheck, spellcheck, spellcheck on 64 bit?

So I run a 64 bit OS on my 64 bit machine. I do this because it’s been YEARS since a 64 bit OS has been available for Linux, to run on 64 bit hardware, and it seems silly not to.

Scrivener has an issue when you try to run it on a 64 OS when it comes to aspell. If you run Scrivener on a 64 bit OS, you get no spellcheck functionality at all whatsoever because it’s looking for the 32 bit libraries for aspell. In Ubuntu in the past the best you could manage was to activate aspell but not access its english libraries, so huge numbers of words on the page would be flagged as misspelled, forcing you to manually add each word to your library–which wouldn’t be saved beyond that session.

The ONLY workaround I’ve seen is to instll scrivener in a 32 bit chroot environment, which is a huge persnickety pain in the backside. You essentially have to install en entirely 32 bit version of linux INSIDE your 64 bit version of linux and then do really annoying and near-incomprehensible things (for me, at any rate) to get it to display x applications. (And what you really need to do is install schroot in order to be able to acess your files).

Basically you have to install a 32 bit OS in your 64 bit OS in order to get SPELLCHECK to work.

Has there been any progress on this situation? I like using Scrivener–I like using it a lot–but I don’t like having to jump through all these hoops just to make the spellcheck work. Spellcheck is pretty important feature for any writing app I use.

has someone found a way to get the 32bit aspell libraries to work, to COMPLETELY work, with Linux Scrivener in a 64 bit environment? Anyone? I need to make some important decisions on my workflow for some things I’m working on in the next few days, and Scrivener is stable enough to be considered for my honest-to-god-actual-work EXCEPT for the spellcheck situation.

I mean, it is just a beta, so I don’t expect everything to work. But this is so fundamental to any kind of writing app that the impression I get is that Scrivener for Linux, as unofficial as it is, is intended only for 32 bit environments, and that this is a PERMANENT decision. Which is completely within the prerogative of the designers, if so–if dealing with the 64 bit environment is too big a hassle then that’s just the way it is, and we’re on our own for workarounds.

But are there any? I’ve yet to see any that work 100% other than chroot, and i can’t really recommend that one because it’s like building an entire house just to use a new door.

Anyway, thanks for any feedback you can provide.

I agree wholeheartedly with this point, 32 bit code is, in my mind, obsolete - and has been for ten years.

Spellcheck is just about the only thing that does work for me though. Using Arch the install is reasonably simple , now that I have helped squash a few anomalies with 32 bit libraries. For aspell I have aspell and lib32-aspell installed as dependencies the only other thing I needed was a dictionary, aspell-en was added separate to the install in my case,

If only I could import my novel I could use Scrivener, but as I can not get importing to work I stick with 64 bit applications like Plume Creator and Storybook, both of which just work.

Ubuntu/Kubuntu quantal (12.10) doesn’t seem to have an equivalent to lib32-aspell, so I don’t have that option. Alas.

You could try this, it is marked as depreciated, then again we both know 32 bit is obsolete anyway.

… that worked!

oh, man, you have no idea how happy I am right now. This has been a thorn in my side since day one. Also, when you try to install the 32 bit libaspell directly (i.e., not lib32aspell but libaspell15:i386) you wind up removing most of the KDE desktop due to incompatible libraries.

Thank you weedfreak!

Ah, very good… that library get’s me so that the spellchecking runs and detects, which is a great start. On my machine (Ubuntu 64bit) it won’t correct those words when choosing from the list, but that’s a small price to pay.

If you are playing with this, note that depending on how you start Scrivener, you may need to log out and back in, or start from a different terminal session to pick up the new library.

I have to walk back some (but not all) of enthusiasm.

Spellcheck works. If you right click on a red-squiggled word it gives you all the right library options. But… it’s underlining words that are spelled correctly. and sometimes it will underline words, and then when you click on the words the red underline goes away.

So… there is functionality there, but it’s not 100% for me. Not sure why… still investigating.

Just to loop back on this… I was right and wrong above. It runs, and it will correct actually incorrect words. But it flags a fair number of other words that are correct. It’s not that it doesn’t know them, because the “suggestions” include the same word, but it doesn’t like it.

Regardless, although a little distracting, it works for me until better comes along. I can always make a final spelling pass in Windows if I have to.