Spellchecking in Spanish (Scrivener Mac) - Mac in English

Hi,

A first-time user here.
I’ve read the previous posts but I didn’t find anything just like the problems that I’m having.

In a nutshell, I’m writing in Spanish, in an English-language Mac, and Scrivener doesn’t recognize the Spanish project that I’m writing, so if I have a misspell, I can’t see the classic red underline highlight that I get from all the other programs.

Do I have to change the Mac’s language in order for that to happen?

Changing the spelling language via (MacOS) → Preferences → Keyboard → Text doesn’t help? It defaults to “automatic”, I believe. Try to change it to Spanish.