Spelling Autocorrect

Hi! I’m trying to find a solution a problem. Scrivener’s auto-correct function often “corrects” words incorrectly. (This most often happens for me with place/people names.) I cannot figure how to turn this function off without also turning off the spell check that alerts you to misspelled words.

I have checked and unchecked “Check Spelling While Typing,” but unfortunately that seems to turn off both functions.

Does anyone know if there is a way to get the settings to do both things at once: to spellcheck while I’m typing, but NOT to autocorrect words Scrivener may think are misspellings?

Thanks!

Have you tried adding those words to the dictionary?

I’ve done that…but it’s quite annoying to do on every project, each one of which has new words to add. Would love a permanent solution!

Hmmm. How would any software know which unusual words are spelled correctly, without telling it? :thinking:

Here’s an example of how it becomes a problem for me.

I just wrote something that mentioned a company called “Paradon,” and Scrivener automatically corrected that to “Paragon” as I was typing. I caught this one, but often while I’m typing I don’t notice the autocorrect happening, and I end up with misspellings in my final product.

What I would like is for the spellcheck to underline the misspelled word as it does in other cases, but to not autocorrect them. (So, to underline “Paradon” as a potential misspelling, but not to change it.)

Is this the Windows or Mac version of Scrivener? (Different spell checking methods.)

When start project turn off autocorrect then do several scenes/ files then do scrivener view and do drop down for spelling. As go very easy to add spelling of word to dictionary and should get new words out of way fairly quickly then turn on spell correct . If turn off spell correct spelling errors are underlined

1 Like

I’m using the MacOS version

Just tried @GoalieDad’s suggestion, it does exactly what you’re looking for.

Hi all, just got this solution and it’s exactly what I was looking for in case anyone comes to this thread in the future. Thank you!

If you go to the Corrections pane in Scrivener > Preferences... , and de-select the option to “Correct spelling errors as you type”, then make sure that “Check Spelling when Typing” is selected under Edit > Spelling and Grammar , that should cause incorrect words to be underlined without autocorrecting them.

2 Likes

Just found my way here while looking up a similar question. I’m working on a nonfiction book, and Scrivener keeps autocorrecting last names that it assumes are typos (e.g., the last name “Kulick” becomes “Klick”). I turned off “correct spelling errors as you type,” and it did indeed solve this problem. The only catch is that I’m not the world’s cleanest typer, and I’d prefer it would still correct things like “teh” to “the” or other random but obvious flubs (like, I just typed “onvious” instead of “obvious” a moment ago). I previously tried adding the last names in question to the highlight/right-click “Learn Spelling” option, but it still kept autocorrecting them when “correct spelling errors as you type” was on. Is there a way to have the best of both worlds in this case, to clean up obvious typos but not clean up capitalized proper nouns? Thanks!

TextExpander or equivalent is perfect for such things. It includes a ton of spelling corrections and lets you add your own.

Similar question. I’m using the latest Mac version and I appreciate having things like uncapitalized letters at the beginning of the sentence autocorrected to initial caps. However, when I’m doing dialog and want to follow “‘Dialog text question?’” with “he asked” it autocorrects he to He. When I hit undo, “he” is now highlighted, so I can’t just keep typing, and that need to use the arrow key or trackpad adds a layer of friction and slows down my (of course utter genius) train of thought.

This happens with other text that gets undone and I’ve never seen this with any other word processing or text management app. Perhaps a bug?

Thanks

Bob, thank you for the suggestion. I hadn’t heard of TextExpander and am now reading about it (and trying to determine if the $40/year price is worth it). I’m a little confused by the website; it seems like they’re mostly targeting IT professionals. Bob, would you mind sharing/explaining a little bit more about how it works and how an author/writer might find it useful? Thanks!

There are alternatives to TextExpander (USD 39.96 per year):

  • Typinator USD 29.99 (All minor updates within the current major version)
  • aText 1 yr USD 4.99, lifetime USD 29.99
  • TypeIt4Me one time purchase USD19.99 (Presumably all minor updates within the current major version)

There may be others.

I had TextExpander for many years, but abandoned it when they went subscription. Currently have aText but don’t use it much. I think the “lifetime price” is new.

Mark

1 Like

Adding to the list: I use the open source text expander espanso

I’m using Alfred’s built-in functionality (which can do really crazy stuff if you trigger custom workflows).

2 Likes

I have a SetApp subscription and use RocketTypist for my text expansion needs.

Alfred’s addition of workflows makes me think I just need to spend some time them up there.

1 Like

Hi. Expanso looks interesting, but the download says M1 silicon. I’m on M2 Pro with MacOS 13.5, and there is one post on the website saying that it’s not working on M2 with 13.4 to which there’s no answer.

What CPU are you running it on, may I ask?

:slight_smile:

Mark

M2 with 12.6.8 (i.e. Monterey latest) – I’m skipping Ventura, as I did Big Sur: a pattern is forming.