Spelling in 3.0 - Spelling not underlining / Different settings for Spelling in Split Pane?

Hello,
I’m having issues seeing my red squiggles in spelling.
I understand that I need to have spelling turned on in Preferences and in Edit menu (command )
However, I don’t see the red underlines. I’m finding that I need to manually select ‘check document now’ either from edit menu, or from the right-click contextual menu in the edit pane.
Having searched previous issues, I notice that back in 2014, KB asked if the user was in split pane or not with a similar spelling issue. Therefore I’ve toggled on split pane and, lo and behold, the right-hand pane shows all the spelling errors underlined, while the left pane I still need to manually ‘step through’ the errors and have them revealed one at a time.
Note that in split pane I’m viewing the exact same document.
What have I missed?

One thing that has been known to cause this problem to appear is the Page View editor layout. Since that is a per-split setting, could it be you have that view set on one side but not the other?