Spelling on Ubuntu 12.04 64 bit

Hi, i’ve just upgraded to Ubuntu 12.04 64 bit. To get spelling working on 64 bit I used to put the libaspell15 and libaspell-dev 3 bit libraries in usr/lib32. But the new Ubuntu doesn’t have a usr/lib32 directory. I’ve tried putting them in usr/share/scrivener/lib (which is where the .deb installs scrivener to) but still no spelling. Anybody have any ideas?
Thanks. Karl.

Try this: robhamm.com/legacy/primary-c … ux-29-beta

Thanks Rob. I already tried getlibs (should have said) but it doesn’t work. The link on your site is broken but I managed to get them from the Ubuntu libraries site. The problem with getlibs is it tries to install the libraries to /usr/lib32 which doesn’t exist any more. As I said I’ve got the 32 bit libraries, but they don’t seem to do anything if I put them in the Scrivener lib folder (if I have put then in the right place). Karl.

If you haven’t already by, why not start by installing ia32_libs–this will pull down the multiarch versions of the libraries. (that’s why there’s no longer a “lib32” directory) After that Scrivener, incidentally, installs cleanly (and runs) without “–force-architecture.”

Did you try moving the 64 bit libaspell15 and libaspell-dev libraries someplace and putting the 32 bit ones in their place? Scrivener might be looking there first, though that would probably break anything else that uses it. Just a thought. Or you might look at $LD_LIBRARY_PATH in your shell environment. Or you might try to find (or build) multiarch versions of aspell and its libraries.

I’m just running Precise in a VM for the moment; I’m going to wait until the point release to take the plunge since I’m going to need to upgrade from Lucid. Then we’ll be in the same boat, mayhap.



I haven’t run ubuntu in a few years, and have no idea how getlibs works, but why not just make the /usr/lib32 directory yourself? If .deb packages work the same way Arch ones do, that’s pretty much what installing a package would do, unless there’s other things in ia32_libs that are needed to run (which is possible)

Also while trying to create an Arch lib32-aspell package I discovered there’s a bit of trickery I needed to get it to find the dictionaries, which install in the 64-bit /usr/lib/ and the I only managed to get it to work by relying on some files from the regular 64-bit version as well. There might be a similar issues going on for you, which could be why it still wasn’t working when you just put it in the scrivener directory. It needs a bit of cleaning, but you can get a sense of how I built it from source from my request for comments on the Arch forums bbs.archlinux.org/viewtopic.php?id=140093 (if you have questions post here rather than there, we have a pretty strict Arch-only policy on our forums)

Yeah, that seems like a good way to break aspell for any other programs, don’t do that for anything other than a temporary test

One of the first things I did after installing 12.04 was to install ia32-libs. I installed Scrivener after that and as you say, it can be done through the software center.
No I didn’t move anything around. As you say it would probably break stuff.
Thanks for your help.

Tried making a usr/lib32 directory and putting the libs in there but no joy :frowning: Thanks for your help.

Hello. I am much more of an amateur than y’all but I’m having the same spellcheck problem with Scrivener in Ubunti 12.04 32 bit. Any suggestions of how to remedy my ailment would be most welcomed. Thanks

Ignore me. Problem solved it seems. Thanks