Split at selection in 025

I just had Scrivener crash when I was trying to split at selection, but I may have been using Scrivener in a non-supported fashion.

I have two monitors, running Windows 7.

I started Scrivener and it opened at the Tutorial, which I had been working through.

I did Open > Project and opened my novel. It appeared in a separate screen, which I moved to the left. This novel is an import from an RTF from a Word 2007 version. I hadn’t made any changes to it yet; it was one long novel.

I wanted to start splitting it up, so I positioned at Chapter 2 The Story Begins (dumb title, but it’s just for my use). Chapter 2 wouldn’t highlight, probably because it was an autonumber Heading1 in the Word version, so I just highlighted The Story Begins and chose Documents > Split > with Selection as Title.

At that point, the little rotating circle appeared, then the message that Scrivener had stopped responding.

Aha! I just tried it again, with only my novel open and got the same result.
I tried just “at Selection” and it also stopped responding.
I tried it without selecting anything, just positioning the cursor, and choosing “at Selection” and it stopped responding.

I tried splitting at the paragraph following and it worked without crashing.

Interestingly enough, after I did the successful split, I tried splitting at an autonumber Heading2, which is how I separated scenes in Word. (Using headings for scenes means I can display the Document Map in Word and see the scene names on the left. I can’t re-arrange or anything, but at least I can see them.)

Splitting the Heading2 worked without a problem. There’s no real difference in the way I set up the autonumbering in the Heading1s and Heading2s, though.

Some more info:

I was using the Blank template the first time I tried it. I just tried using the Novel template. I got the same results whether I imported the .doc version (not .docx) or .rtf.

Again, love the product and appreciate all that you’re doing for us!


I went back to my original .doc file and changed the Heading1 and Heading2 styles to NOT use autoformat.

I saved it as RTF.

I imported it into Scrivener.

I used Ctrl-K to split at selection, and it worked, with no crashing! So, I think the problem is with autonumbering, Word 97-2003 (doc) format.

I’m all happy :smiley:

Another poster seems to be having problems with autonumbered headings in Word:

That poster also mentioned a problem with a footer. Just out of curiosity, I checked my original document. Mine did not have a footer.

Since there’s a workaround for my problem (turn off autonumbering in Word before importing), I’d personally be happy with that being a known bug for now. I’m not sure how important it is for others.

Thanks for the report! There do seem to be some issues with importing Word documents containing certain styles. Did yours have an overhang indent? That’s one that can cause a crash once you try to work with the document in Scrivener.

Sorry the Known Bugs list is a little out of date; I need to get that together this week and I’ll make sure this is on it.

Oh, this is interesting. I usually just put in a left .05" indent on the paragraph when I format manuscripts. Here are the settings I had:

In the Indentation section of the Paragraph dialog box, it says:

Left 0.06"
Right 0"
Special: First line By 0.13"
Mirror indents is not checked