Split editor layout question

I usually leave Scrivener open all the time with multiple projects. I have a layout problem that is continuing to occur and I don’t understand it.
I have the editor split vertically. When I do the split, the split is done such that the two editors are equal size horizontally. I edit away for while, then get distracted and go down some internet research rathole. After going through a number of other application windows that I have open, I return to Scrivener by clicking the dock icon. The editors on the project are still split vertically, but now the one on the left is about 25% of the editor space, the one on the right is 75%. This is happening consistently. How come?

I am running Scrivener 3.1.1 and macOS 10.14.1. I don’t use any custom layouts, just the default.

I have now determined that this only happens when the display has gone to sleep. After I wake it up, the size of the Scrivener editors has changed from 50-50 to 25-75.
Also, I think this only began happening after I switched systems. For years I have been running a 2013 27" iMac. I now have a 2018 Mac mini and my monitor is an LG 24UD58-B, a 4K monitor. It is connected via USB-C to Display Port cable.
I have not noticed any other applications doing weird layout stuff after sleep. However, when I bring the monitor out of sleep, the first login page image it flashes only covers about the left half of the display. Then it blanks, then gives a full display login window.
All pretty strange.

That is indeed very strange, and not something I’ve ever encountered or seen reported before. From your description, it sounds as though your whole screen is resizing somehow while the computer is sleeping, and then restoring itself on wake. Looking this up, there are a couple of posts out there on forums about the Mac Mini that report something like this, but I can’t find anything definite. My guess is that when the display goes to sleep, the Mac Mini can no longer detect it and so switches back to some default screen size, then resizes again when the display wakes.

If the screen resizes (and that is almost certainly what is going on given your description of what you see when the screen wakes), then macOS automatically resizes all windows. This could easily lead to what you are seeing. Unfortunately there’s not much that Scrivener can do to avoid this, because there is no way for Scrivener to tell the difference between the user resizing a window and the system resizing it, and certain UI elements have to take priority over others when resizing.

However, a couple of things may help:

  1. In the Preferences, under Appearance > General Interface, try ticking “Always resize editors proportionally when resizing window”.

  2. You can quickly make the editors 50/50 again by double-clicking on the divider between them.

All the best,
Keith

Thank you, Keith. I’m sure you are right about the change in resolution as the monitor comes alive from sleep. Your suggestion to change the preference to “Always resize editors proportionally when resizing window” solves the problem for me. And I didn’t realize (but should have) that double clicking the separator would equalize the windows.
Now for the longer response–irrelevant to Scrivener, but interesting, I think.

External monitors in macOS seem to be a challenge for some reason. The Mac mini with external monitor (obviously), is very different from the 27" iMac I have used the last five years. The first thing I noticed was how long it took to wake an external monitor up from sleep–five to seven seconds on the external monitor compared to it being essentially instantaneous on the iMac. I started with a Dell P2415Q (24" 4K) and connected it via HDMI because that’s the cable I had. The Dell was very slow to wake from sleep. In addition, I managed to mess it up so it wouldn’t wake from sleep at all without restarting both the Mac mini and the monitor. I looked around and found an LG 25UD58-B (also 24" 4K) for $120 less and tried that. I ran it both from HDMI and USB-C to Display Port. I found the Display Port connection was quicker to wake by 2 seconds or so. In addition, using Display Port, I could manipulate colors and brightness on the monitor directly from macOS rather than going through the monitor’s menu using its collection of buttons. So I went with Display Port.

Now, after seeing this problem, and your response, I decided to see if this behavior was the same when the monitor was connected via HDMI or Display Port. It is not. With HDMI, the monitor doesn’t flash the altered screen resolution and Scrivener doesn’t change its layout.

This is nuts. How can macOS be so good at so many things and so dumb at something that should be pretty basic–like plugging in a monitor with standard connections?

Now, as a bonus for reading this far, let me say that participating in this forum is always satisfying. I see few irrelevant posts, and little of the silly bickering that appears regularly on other forums. On this forum, I see questions answered, and creative solutions suggested to challenging problems. It’s fascinating to read even if the problems aren’t mine or particularly relevant to my usage of Scrivener. Thanks to all.

I must say that Scrivener is my favorite program. I think you can do anything in Scrivener, you just have to figure out how. Back in the day we said that about the Unix command line, and about Vim. Scrivener is prettier and more fun.

Huh, that is curious. I was wondering why I never had this problem with my external monitor - although I use an iMac Pro for development, for writing and everything else I use a MacBook, and plug it into an external monitor when at my desk. But of course, I use an HDMI connection for that, so from your tests, that will be why I’ve never run into the problem. Unfortunately, despite Apple products generally making connectivity, they are prone to a few blind spots like this. (It still baffles me, for instance, that I cannot plug my iPhone into my MacBook without either a third-party USB-C to Lightning connector or a converter.)

Thanks for the kind words about Scrivener! I’m glad you’re find it, and this forum, useful.

All the best,
Keith

One more interesting tidbit about this issue. I believe it is caused by the system changing the screen resolution when the monitor powers up. I don’t actually have to sleep the monitor from macOS to make it happen. If I just turn the monitor off and then back on, the resize occurs and the Scrivener window changes.

Ticking ‘always resize editor proportionally’ does fix the problem of the editor windows being unequal sizes, but in some projects Scrivener also changes the width of the Binder when this occurs. I normally have the binder expanded a bit from default to more easily read my wordy document titles. When the display sleeps, on awakening, the Binder on some projects is resized to a much smaller width. I have worked around this by saving and name a layout and I can just set my layout and get everything back, but it is a bit of a hassle.

But the real interesting part is that this problem only occurs on some of my projects. I have multiple projects open in Scrivener usually and their layouts are similar (but are not set by being assigned a specific layout–I have not used that feature much). On most projects, I have the binder set pretty wide. On two of the four projects I am currently working on, when the display goes to sleep, the binder width is changed when it comes alive again. On two of them it is not changed.

I have tried setting the layout to ‘default’ and this does not change the behavior of the projects. Neither does manually resizing the binder. So projects where the binder size doesn’t change work seemingly regardless of the layout and the others don’t.

Any ideas as to what setting may be different? Any way to check differences between the settings for the projects by comparing some file in the project package?

Hi tbrown313,

I’ve got nothing to contribute re: your screen resizing challenge, :frowning: but when I noticed the above point in your OP. I couldn’t stop myself from jumping in. My assumption is this means you don’t regularly close Scrivener?

If so, just wanted to confirm that you’ve got your backup process set up accordingly. For instance, do you take manual backups regularly?

I’m asking because two to three times a month, sometime more often, we get posts on the forums from folks who have Scrivener set up to backup on close, but then never close Scrivener, and when disaster strikes and they need to restore a project, discover that their most recent zipped backup is weeks or months old.

Hopefully that’s not you, and sorry for butting in with an off-topic post. :smiley:

Best,
Jim

Jim,

Thanks for the warning. Although I rarely close Scrivener on the Mac, except when rebooting, which also happens rarely (once or twice a month?), I routinely edit the same files on my iPad. I have Scrivener on macOS set to backup before syncing with iOS, so every time I switch back and forth, I get a Scrivener backup.

Also, I use Time Machine for local backups and so I have many Time Machine backups of the Scrivener files even though I may not have Scrivener backups. Since Scrivener auto-saves (I have this set to 2 seconds of inactivity. Of course, while I am writing, I never have more than two seconds of inactivity!) I believe Time Machine backs up my Scrivener files routinely, and I took a quick look to verify this.

I also use Blackblaze for off-site backup, which would make me feel lots better if my house burned down.

So I think I’m covered pretty well. Let me know if you disagree.

Hi Terry,

So Mac Scrivener creates a zipped backup when the project detects a DropBox sync? That’s clever. Do you need to press Mobile Sync to make it happen?

The current Windows version has the Mobile Sync & backup before syncing features, but for whatever reason it didn’t work so well me. I couldn’t get it to sync using Mobile Sync, much less create a zipped backup–although Windows Scriv will create a zipped backup if the data is synced prior to opening the project. Perhaps Windows v3 will handle this better, or perhaps it’s just something to do with my setup.

It sounds like you’ve done your homework and have it nailed down! :smiley:

Best,
Jim