Square brackets causing a problem

As I work on a new edition of a book, I make notes to myself. To be sure they are all removed before publication, I put them in double square brackets (to make searching easier).

When I type double square brackets at the end, Scrivener tries to make a linked document and then erases the brackets — very frustrating. How can I turn this off?

Preferences | Corrections

In the Substitutions section remove the checkmark beside Automatically detect [[Scrivener Links]]

As an aside, have you considered using inline annotations for the notes? These can easily be automatically removed during compile just by ticking the option under the Footnotes & Comments settings in compile. (It’s already ticked by default in most compile presets.) They’re also easy to identify in the text by colour and the bubble around them, and with the Shift-Cmd-A shortcut they’re as easy to type as the double-brackets.

That said, RegEx compile replacements can also easily strip your double-bracketed notes, and if that works better for you, great! I just wanted to point out the annotations in case you hadn’t been aware of them.