Srivener 2.5 compatibility with Mac OS 10.6.8

Hi there.

Simple question: is Srivener 2.5 compatible with Mac OS 10.6.8?

Thanks in advance for your help!

IGH

I’m currently using 2.5 on my beloved three plus year old Macbook Pro running 10.6.8 (no new mac for Christmas, darn it!). Scrivener runs perfectly on it.

Thanks so much Jot, that’s what I needed to hear. I have no plans to update to Maverick just yet, but will now proceed to update Scrivener. Appreciate it.

IGH

I am stuck with Snow Leopard (10.6.8) on my iMac too and am working very happily with Scrivener and Dropbox and Scrapple.

Scrivener 2.5 is still compatible back to Mac OS 10.4 Tiger. :slight_smile:

My writing partner and I work on 2007-08 era iMacs.
Love those 24-inch screens, which Apple has abandoned. :imp:
We have no trouble running Mavericks OS plus the latest Scrivener.
With older machines, it’s often good to expand memory.
We both have 4 gb installed; it’s a cheap way to update.
Just my two sense. :open_mouth: