Start Pane Behavior [ADDRESSED]

I’m unsure if this is intended behavior or not. It could be Mac design conventions clashing with Windows design conventions, I don’t know.

When I started Scrivener for the first time, I got the “Create New Scrivener Project” window. I created a new project, and imported some text into it. But when I close the Scrivener main window, the “Create New Scrivener Project” window is still there, waiting for me to close it. I had assumed that this window would disappear after I’d either created a new project or loaded an existing one.

The second time I opened Scrivener, it auto-loaded my previous project, but the “Create New Scrivener Project” window still loaded behind the main Scrivener window – it lurks back there until I exit the program.

I unchecked the “Show start panel when there are no projects open” box, and restarted the application. The “Create New Scrivener Project” window didn’t appear on startup, and it jumped directly into my most recent project. But when I closed the application, I discovered the “Create New Scrivener Project” window was lurking in the background.

I rechecked the “Show start panel when the are no projects open” box, and unchecked the “Open recent projects on program launch” box, then restarted the application. It jumped directly into my most recent project anyway.

Then, I unchecked both of those boxes, and found the “Create New Scrivener Project” appeared on launch. I have since rechecked both boxes, and it once again jumps into my most recent project while loading the “Create New Scrivener Project” in the background.

Is this intended? My expectation was that if the software was going to load the most recent project, it would skip generating the “Create New Scrivener Project” window completely.

Additional information:

I’m running Windows XP, Service Pack 3, with all the most recent updates installed.

Hi Strangefork - I am testing on WinXP Sp3 and am unable to replicate.

Not sure how I missed the checkbox for so long, but it too was driving me nuts having the project menu waiting for me when I closed a project.

Unchecked the “Show start panel when there are no projects open” box, closed Scrivener. I left the box checked to open recent projects.

So now when launching, it goes directly into my most recent project and on close exits the application without seeing the project menu.

It almost sounds like your application preferences aren’t taking. How are you exiting the option menu? Just clicking the red-X?

viewtopic.php?f=32&t=8778

That thread covers how it might be confusing with no “Ok” or “Save” button. Lee has said in the next beta he will add that. Though might not be the issue here unless you are accidentally clicking the “defaults” button when trying to exit. (As I did a couple of times before actually reading the text of the button :smiley: )

I’m getting the same behavior.

Every time I exit, the Create New Project window appears.

Here’s what I’m doing:

  1. Select Scrivener from Start.
  2. It opens up in my current book.
  3. I hit the Red X to exit.
  4. The software disappears and the Create New Project window appears.

It appears to be related to using the X to close the window. When I go to File -> Quit, I don’t get the window and it exits correctly.

Hi The Pencil Neck - what are your options set to?

Edit > Options > General (tab) > Startup Options (top two checkboxes)

Scrivener, in beta 1, is set by default with the option “Show Start Pane when no projects are open” to checked. Have you unchecked this box, closed the option menu, and reloaded Scrivener?

Olorinpc:

I just went back and unchecked the “Show Start Pane when no projects are open” box, and then closed and relaunched – bingo. Works as I expected. Thanks for pointing that out.

No problem - I had it once mysteriously recheck itself, but who knows I might have hit the defaults button or something.

It was explained in some thread I can’t locate at the moment, but it was designed to default that way because that is what the mac version does.

Thanks Jakob.
Lee

No problem Lee :slight_smile:

Helping out where I can - I am sure it is way more crazy on your end!