Starting a new indented paragraph with Enter

I apologise if this is really obvious but I’ve searched around and it’s pretty hard to narrow down topics with the words “enter” “tab” and “indent” since there are so many. So, apologies!

I just did something in Full Screen and have no idea what. Until now, if I hit Enter in the editor, say I wanted to break up a paragraph into two and hit enter at the start of a sentence, it would bring that sentence down into a new, indented paragraph.

Something I did just now has seemingly undone this, so now whenever I hit enter, it just drops the line down with no tabbed indent.

Can anyone tell me how to change it back? I looked through the Preferences and saw the Return behaviour boxes under Formatting but that doesn’t seem to be relevant.

Please help!
:confused: :slight_smile:

…And for the record, I have my ruler showing, and this is where it gets weirder. The indent is shown on the ruler only sometimes. This all started today - no updates, nothing new with my Mac. It was like I accidentally hit a key combination, and now the indent tab is set sometimes, and as I’m scrolling down, editing, and decide I want a new paragraph somewhere, I hit enter and on the ruler, it decides to suddenly remove the tab.

I read another thread about this but no conclusive fix seemed to be suggested, other than some people just don’t have this issue.

Frustrating as it’s been working fine for about 4 months now!

There are a lot of factors that can be involved here. Since RTF is the underlying format, it is possible to have a paragraph with a set of tab stops and indents one way, and then the very next paragraph can be completely different. If you do all of your writing in Scrivener, this shouldn’t ever deviate unless you mess with the ruler or Presets—but if you paste anything in from another application, it is possible to get external formatting applied in the middle of your document. The way things work around this deviation is that if you start writing from the paragraph, its “incorrect” formatting will be used for further material.

Consequently it is possible to end up with pockets of weird formatting. This can all be cleaned up with the Documents/Convert/Formatting to Default Text Style menu command at any time, mind, so it isn’t a huge problem but it is something to be aware of.

Now, if you create a brand new item in the Binder and start typing in it, and the formatting isn’t how you prefer, then do check out the Formatting preference pane and make sure the sample paragraph looks the way it should. Use the mock editor here to fix it as necessary.

Otherwise, it is possible to insert a line feed instead of a paragraph break, and doing so would cause the symptoms you describe. Line feeds create new lines within a paragraph and so its initial-line indent settings will not apply to the new line as they are not technically the first line of the paragraph. It would be difficult to do that accidentally though, as you need the Option and Command keys held down in conjunction with pressing Return. To check for that though, use Format/Options/Show Invisible, and look for down-and-left pointing arrows on the end of lines, instead of a pilcrow.

I’d say its more likely you just have multiple styles going on, though.

Just what the doctor ordered. This was driving me nuts. I was trying out Mellel and c/p it all back in Scrivener and every thing (well indented paragraph things) was wrong. Good to get it sorted. :smiley: :smiley: :smiley: