Stop Capitalisation on New Line

I write poetry (primarily). Some prose. Both V2 and V3, capitalise the first letter of a word on a new line (after both soft or hard return). This happens for the Blank template, and poetry template, and even for a custom template I tweaked from the Blank one. My fix over the years of using V2 was to delete the Cap letter, retype it in lower case, and manually move the curser somewhere else in the editor. If do that, the lower case letter sticks - problem solved. After playing with V3 for 3 days, I see that the same issue remains. There are times when Caps on each line is required by the publisher, but there are also times when aesthetics overrules, and I don’t want this to happen.

And besides, as a touch-typist this mucking about with the curser is counter-intuitive and a waste of time.

Is there a fix that my searching LL’s site hasn’t revealed? Perhaps I’ve missed instruction in the User Manual, which I’ve over and over. Any help is greatly appreciated.

Thanks.
CapsAfterHardReturn.png

Check this in Scrivener’s preferences.

And this in macOS System Preferences.

Two ways to do it: which you use depends whether you want to retain the capitalise first words feature elsewhere.

If you’re happy always to type your own capitals, then turn off the feature in Preferences > Corrections > Auto-Correction and untick ‘Fix capitalisation of sentences’. (See Bridey’s post above for full details.)

If you want to retain the feature because you use it elsewhere, then use Insert > Break > Link Break, which doesn’t insert the paragraph marker.

Obviously this requires you to use a shortcut rather than the Return key for poetry — the default is cmd-opt-return. On my system that conflicts with something else, so you may have to do a bit of shortcut juggling in System Preferences > Keyboard > Shortcuts. This is very easy, but ask if you need help.

HTH

Perfect! I am indebted to you!

I’ll keep that in mind, first trying if a conflict exists on my system as well. As a touch-typist, I’m quite used to flicking my little finger at a shift key, so now I’m sitting happy after de-selecting that feature in ABC-Correction.

Thank you everyone!!

Dang that checkbox in the System Preferences! When did that get added? I see it’s there in 10.12 but I never noticed it. It turns out that the auto-caps option there doesn’t do anything unless you have both spell-checking and auto-correction turned on, which is no doubt why I’ve never noticed it, but yes, it turns out that if you tick that, you can get auto-capitalisation in Scrivener (if you have spell-checking and auto-correction turned on) even if you have Scrivener’s own auto-caps turned off. And unlike all of the other auto-correction features, for some bizarre reason, Apple has not provided a way of turning that feature off per-text view. For 3.0.1 I’ve found a way of overriding the behaviour, though, so that it will have no effect on Scrivener’s main editor if you’ve turned off auto-caps in Scriv.

All the best,
Keith

As I’m (slowly and cautiously) migrating everything over to V3, unticking the option in Scrivener did the trick for me. I still have V2, needed for several chapbook MMS, and happily unticking the Scrivener’s auto-caps did the trick there also. Thank you again for the assistance.

Hello, Keith.

Don’t want to distract you from 3.0.3, but I found this thread while researching another thread…

literatureandlatte.com/foru … =2&t=52378

In this thread, you say…

Apple’s support docs refer to a per-text Correct Spelling Automatically menu option (which is available in TextEdit etc)…

It is also in the human-interface guidelines…

Have I misunderstood, or is this the per-text Correct Spelling Automatically option you mention in the quote above? If Scrivener included that option on the edit menu, would the auto-capitalisation be more likely to work, and allow users to have discrete settings for each project?

Thanks.

We are talking about different things. I was saying that Apple has not provided an option to explicitly turn off capitalisation in a text view. If auto-correction is turned on for a text view, then capitalisation comes with it automatically (but I worked around that).

Currently, Scrivener provides its own auto-capitalisation routines and does not use Apple’s. Even if it used Apple’s, there would be no way of turning it off per-project - you would need to turn off auto-correction to turn off auto-correction.

All the best,
Keith

Thanks, Keith.

Hello L&L gang!

After reading all these helpful posts and trying several of the things suggested to stop Scriv 3 from auto-capitalizing the first line of my poetry, here’s the problem I continue to have with Scriv 3.1.5 operating on Mac OS 10.14.6:

Scrivener will not accept my de-select of “Fix Capitalization of Sentences”! (Under Scrivener/Preferences/Corrections/Auto-Correction.)

I go in, I de-select it, I hit “Defauts” at the bottom, it asks me if I want to continue, I say yes, and then it re-checks that “Fix Capitalization of Sentences” box before closing the dialog box on me!

I have tried first going into Apple/System Preferences/Keyboard/Text and de-selecting “Correct Spelling Automatically” and “Capitalize Words Automatically” and then restarting my machine. Now, those de-selects DO stick.

And yet something seems to keep overriding my de-select attempts in Scrivener.

Another thing … must I go through this process for each individual poem in my “Poetry” project file?! I seem to deal with this issue again and again … how do I get to one-and-done?

Thanks in advance! :slight_smile:

The “Defaults” button resets everything to the default values before you started fiddling with the settings. Just don’t click it, and you’ll be golden.

Oh! :open_mouth: Thank you, rdale … The language in the Defaults alert is not exactly the clearest!
Now I know. Cheers!

The only way I am able to stop sentence capitalization is by unchecking capitalize words in MacOS system preferences under keyboards–> text and unchecking Scrivener setting of Fix capitalization. Just unchecking at Scrivener preferences is not working.

MacOS wide setting is affecting many other apps though. Is there any solution or work around?

Hi, I seem to have the same problem here (the first few words of the title seem to be capitalised CHAPTER ONE: THE LITTLE Pied Cormorant.)
Unchecking the box for Fix Capitalization of sentences DOES NOTHING to remedy this problem and when I compile, the same problem occurs.
I am not clicking on Default and when I go back into Preferences-Corrections-AutoCorrection, the box for Fix Capitalization of sentences is unticked. Yet the file continues to capitalise the first sentence so that half the title is in capitals and the other in lower case.

How have people fixed this error?

I doubt it, since it’s natural for the software to think a new line starts a new sentence … but you can use Undo (immediately) to undo the capital.

Are you perhaps talking about the first few words of a chapter being made uppercase when you compile the project? That’s an entirely different matter from the auto-capitalization when typing in the editor being discussed here, based on settings in the compile format you’re using and not related to either Scrivener’s or the system’s preference settings.

You can remove the first-words uppercase setting by double-clicking the compile format and choosing Duplicate & Edit, then in the Section Layouts finding the layout used for chapters, clicking the New Pages tab and setting the Number of opening words to make uppercase to 0.

Usually, this setting would apply to the first few words of the chapter following the title, as the beginning text of the document, so it sounds like you may be including the title itself as text in the editor? Generally you’ll be better off using the title from the binder as the document title, and/or using the Title Prefix or Title Suffix options there in the compile Section Layouts to insert titles like “Chapter One”. “Chapter Two”, and so on. For one, that lets you use features like the “opening words to make uppercase” without them being applied to the wrong text. :slight_smile:

You may be far enough along in compiling and completing your current project that it’s not worth changing what you’ve already done, but it’s something to consider next time around. The Novel project template is a good demo of this; you can rename the “Chapter” folders whatever you want in the binder, but they’ll compile with the given format as “Chapter One”, etc.

Then again, I may be completely misunderstanding what you’re seeing regarding the capitalization, in which case perhaps you could describe the steps and result that leads to the problem and we’ll better be able to help you.

Thank you.

“You can remove the first-words uppercase setting by double-clicking the compile format and choosing Duplicate & Edit, then in the Section Layouts finding the layout used for chapters, clicking the New Pages tab and setting the Number of opening words to make uppercase to 0.”

This did the trick. I didn’t know which of the layouts was causing this issue (I tried this on a few of them without success) so I went through all of them and changed every single one of them from 3 to 0. Now it compiles without capitalising the title’s first few words.
Curiously, my first ebook didn’t have a duplicate e-book setting for compilation (i.e. just used the standard ebook setting) and this problem did not occur then.