Strained system resources, excessive use of system resources

Regards

OSX 10.4.8
MacBook Pro 17 in intel, 2 gb ram, 2.16 GHz core duo

When I am pounding away writing in Scrivner I often get the spinning disk and have to wait while the system grinds away, often for 30 or 40 seconds, over and over. Using activity monitor there is a gigantic spike in cpu usage when your program is running. Very often this delays thought and writing and becomes a little frustrating. This is such a fast computer I don’t really understand why the system gets dragged down while I am typing.

I have gotten some relief by changing the auto save timing from 2 seconds (default) to 2 minutes.

The comes about if I have many programs open or only your program open.

Perhaps this is a rosetta problem? Is the program running natively on intel macs?

This is a strange obstacle inside a great program. Many thanks.

Turtle Heart
Ojibway Artist
Pantelleria Sicilia

I have never seen or heard of this problem. How big is your project? Not that this should make a massive difference, except that auto-saves will be slower the bigger the file, obviously.

Scrivener is Universal, so it is most certainly not a Rosetta problem. All Scrivener testing has been done on slower machines than the one you have, without any of the issues you have.

Do you have anything special installed on your system? System hooks and so forth? Anything else that might be trying to interact with Scrivener? This is a very difficult one to answer, as Scrivener has a couple of thousand users, most with slower machines than you, and this is the first I have ever heard fo a slowdown problem…

Best,
Keith

EDIT: Looking at Activity Monitor, CPU usage does seem a little high whilst typing very fast in some situations, so I will look into that. However, I am not convinced that this is the problem given that this doesn’t cause slowdown for others…

Hey Ciao

Thanks for replying so quickly. The program is just great, as many have said, I am really flying along with my project. get info says the project folder is 270 megabytes right now.

When it saves does it save everything over and over or only the document I am working on, usually a “chapter” in the draft window right now?

Well I appreciate your thoughts. This mac book pro calls out to the system far to often and likely as you suspect it may be a specific issue with my system, yet it is true that when I am using your program it is sometimes pretty bad, worse than most of the time with other programs. Particuarly when I am typing my thoughts quickly and freely. I note your advisement that others have not reported this problem. Are you hearing from other new intel mac users that they are using your program ok?

many tnanks

Turtle Heart
Ojibway Artist

I use it on both my G3 iBook and my Intel iMac, both running 10.4.9. Don’t have any trouble at all on either one.

My files aren’t nearly as big as yours, though. Mine are just straight text, no pics or PDFs or anything, and the biggest one is 3 MB - a far cry from 270.

Hi TurtleHeart,

Scrivener was originally developed on an iBook G4 1GHz, then it moved to a MacBook Core Duo, and now it is developed on a MacBook Pro 15" Core 2 Duo 2.15 GHz with 1Gb memory. So your machine is faster than anything it has been developed on…

As for saving… Scrivener only saves the binder.scrivproj file that is inside teh .scriv package, and any files that are marked for saving (that is, any text files that you have changed since it was last saved). Could you do the following for me?

  1. In Finder, select your .scriv file.
  2. Ctrl-click and select “Show Package Contents”.
  3. Look at how big the binder.scrivproj file is.

If the binder.scrivproj file is very large, this would explain the slowdown during saving. Also have a look at how big binderStrings.xml is, though that is less likely to be the cause of the slowdown than the binder.scrivproj.

binder.scrivproj should not take up hundreds of megabytes, though - I would imagine the size of your project is because of PDF, image or media files that have been imported, and if this is the case, these won’t cause slowdown because they are not re-saved or anything.

I have just this minute tested Scrivener on a .scriv file that is 417MB large, which contains a 1.2MB binder.scrivproj file and a 40MB binderStrings.xml file. I encounter no slowdown whilst typing at all. Saving takes a couple of seconds, but saving does not kick in until the app is inactive for two seconds.

What is your typing speed? If you are a relatively slow typer, it is definitely a good idea to extend the auto-save time.

Here is a way to check to see if it is the auto-save that is causing issues: when the spinning beach ball kicks in, does the red (or grey if you are using graphite theme) button in the top-left corner of the window have a dot in it (which indicates that a save is due and it might be saving now)? But you say that setting a longer auto-save time doesn’t help, so I am assuming that this is not the issue…

I have added it to my list to check the way CPU usage goes up occasionally, but like I say, I don’t think this is the issue given that a 400MB file works fine on a lesser machine…

Best,
Keith

.
3) Look at how big the binder.scrivproj file is.

right now it is 20 kb. I removed a 140 mb photoshop file which I can do without at the moment.

What is your typing speed? If you are a relatively slow typer, it is definitely a good idea to extend the auto-save time.

Depends. Can be quite slow when copying as i use 2 fingers and still after all these years have to look at the keyboard. But when I am freely writing what is on my mind it goes very fast. Not sure the actual speed in wpm.

Here is a way to check to see if it is the auto-save that is causing issues: when the spinning beach ball kicks in, does the red (or grey if you are using graphite theme) button in the top-left corner of the window have a dot in it (which indicates that a save is due and it might be saving now)? But you say that setting a longer auto-save time doesn’t help, so I am assuming that this is not the issue…

When tis problem kicks it it is at the auto save moment. usually the dot is there at the beginning…

I have added it to my list to check the way CPU usage goes up occasionally, but like I say, I don’t think this is the issue given that a 400MB file works fine on a lesser machine…

I am begiining to believe it is an issue with my machine and not your program. I think from my reading that there have been a lot of problems with these first generation mac book pro laptops. As a general rule I don’t think it is a good idea to buy first generation macs but in this case I had no choice. Thanks very much…
[/b]

Are you experiencing similar problems with other apps? In the past I had things like that happen randomly, and it turned out it was because there were bad sectors on my hard drive that would stall or lock up completely when data was being read from them. Hopefully it’s nothing that serious.

I have nearly an identical system, MacBook Pro 15" dual-core 2.3Ghz w/ 2GB RAM and it is smooth for me. Very smooth. I probably have about 40 to 50 documents in my project and mostly text–only 4 imported PDFs.

I suspect, as suggested, it is something you have installed/tweaked on your system that is the problem. Let me know so I don’t do the same thing! :wink:

I too have a first generation 17" MBP, and I have not suffered that with Scrivener but my projects are nowhere near the size of yours. I too would wonder if you had anything installed which was causing it, or some hardware issue on your machine.

Mark

I removed a 140 mb photoshop file which I can do without at the moment.

So just to update. By removing this big photoshop file with a layer this problem seems to have gone away.

I had this psd file in the refrence section of a project (dragged and dropped it there), but a smaller edit version is all that I really need there…

anyway I was wondering what the thoughts are in having big files inside a project. If the beg image file was the system delay problem in what way was this program interacting with this file?

TurtleHeart

That is very strange, given that Scrivener shouldn’t be interacting with it in any way unless it is being viewed (or shown as an index card in the corkboard). Weird.

I have a similar effect like turtlehart. (MacBook 2Ghz Core Duo 1GRam) My file is (compared to 470 MB) very small (15 MB) but has a lot of text snippets nearly 3000 (also in the trash). Maybe thats the reason why.
It often slows down handling/typing text. Once SC crashed in projekt statistic , i had checked include sub-documents. The binder remains fast. Sometimes the fan starts. Hope that helps. (BTW dont missunderstand me, its a great tool)

wolfgang

@ turtlehart
do you use Devonthink with a big db at the same time?

wolfgang

The Project Statistics bug is a known one and on my list of things to fix.

Could you please send me the 15MB file that is causing such slowdown? Send it to support@literatureandlatte.com and hopefully I can track what is wrong.

Many thanks,
Keith

I’m also suffering a little slowdown with one of my projects. The scriv file is close to 62 megs, binder.scrivproj is only 28KB, and the binderstrings.xml file is 16.2MB. I have 16 PDFs, a note file associated with each one, and a few general outline documents.

I haven’t tried to reduce the autosave frequency, but running this file has a way of using all of my system resources. Generally I’d have 100 megs free listed in top, but with this file open I drop down to 10 or 15 megs. Typing speed suffers a lot.

At any rate, I wanted to toss this problem into the ring.

Macbook 2g Core Duo, 1G RAM

Hi,

recently I started experiencing the same speed loss as well ( an a G5 and a G4). My projects did not get significantly bigger since winter. :cry:

Maria

Anyone suffering severe speed-loss should zip up their projects and send them to me. Honestly, I can’t fix anything without experiencing the bug myself.

If you don’t want me to read your words (I wouldn’t want anyone reading mine :slight_smile: ), here’s what to do:

  1. Make a copy of your project in the Finder.
  2. Open the COPY of your project in Scrivener.
  3. Go to Find > Replace All and start replacing random letters - e.g. “a” for “s”, “t” for “q” and so on. Do this five or six times and your text will be utterly unreadable, complete gibberish (do NOT do this on your original file!!!).
  4. Check that the speed issues still affect the copied, gibberish project (if not, you may just need to trash your preferences file).
  5. Zip up the file and send it to support@literatureandlatte.com

Please make sure that the slowdown is very noticeable, as I use an MBPro and need to see the effect myself - though I can break out the old iBook G4 if I need to. :slight_smile: As I say, I have a project with thousands of files and hundreds of thousands of words in it, and experience no such slowdown…

Thanks and all the best,
Keith

Hi,

yesterday I cleaned all cashes since Christian vom DT recommends so in similar cases. It did not get better, but it got better when I copied the files from my thumbdrive on the hard disk :wink:

I did not think that the thumb drive would cause such a slow down. Is there anything you can do about the performance with storage media from Scrivener side?

The thumb drive is after all the best choice to work on two computers, since Scrivener does not provide any tool to check which files one has worked on most recently (to compare two versions on two computers).

For the time being, the reason for slow downs seems clear in my case.

Best,
Maria

Thumb drives are slow. It’s a side effect of the type of memory they use. The only thing the application can do about it is minimize the number of “disk” accesses by loading as much into main memory as possible. That’s obviously constrained by your system memory, and doesn’t help with saves.

One alternative you might want to consider is to use an iPod in disk mode as a portable hard drive. The nano and shuffle use the same kind of memory as a thumb drive, but the larger iPods use small versions of the same technology as your computer’s main disk and are therefore much faster.

Katherine

Katherine,

Thanks for the suggestions. I should have bought a bigger iPod, recently I decided for a nano, which was just stupid (small Japanese unreadable, and now the speed problem…)

Thanks anyway, I will have to say goodbye to the thumbdrive, sigh…

Maria

USB 2.0 flash drives are pretty speedy. I’ve got a 512MB Memorex flash drive, and as long as it’s plugged into a USB 2.0 port (or a 2.0 hub which is plugged into a 2.0 port) it zips right along. If it’s in a USB 1.1 port, though, it’s slow.