Strange behaviour of new chapter

Using version 2.5.25239 on a Mac running OSX 10.6

I’m working on a story of which I have three chapters completed. These three chapters were written around Christmas and since then I have been working on another piece, and came back to this story only today. I have read through my three chapters, making a change of a word of two here and there, sometimes a change of word, sometimes an addition of several words, with no problem.

When I came to starting chapter 4, I marked the left window entry ‘Story’, pressed the plus sign on the toolbar and got up a new chapter window with everything apparently normal - correct line spacing, correct first line indent, correct font and size.

But when I come to start writing, I come to the right margin and text does not continue to be entered, however much I type. The text does not wrap, but neither does it appear to disappear off to the right. It just stops being entered.

I have tried erasing a bit of the line and trying again, I have tried erasing the chapter and starting a new one. The new chapter displays the same characteristics. I have also closed the particular project and re-opened, and even closed Scrivener and re-opened it, all to no avail.

Before starting today’s work, the last time I opened Scrivener was yesterday or the day before, when I edited another piece, a short story. I did not notice any problems then.

Any suggestions?

I’ve managed to get round the problem by making a copy of an earlier chapter and erasing all the text in there. However, if I add another chapter by marking ‘Story’ and clicking the Add button again, I get the same behaviour as described in the OP.

I assume that this is a format problem, though how this strange change has crept into the format and how I get rid of it, I don’t know,

Hmm, that doesn’t sound like a typical formatting problem, but it could be something unexpected, and it does match the symptoms considering a copied file (with its own formatting) handled fine. What I would do is go to the Formatting preference pane, where the default look of a document is generated. Load a normal text body paragraph in the project window, put your cursor in it, and use that “Use Formatting in Current Editor” button in the preference pane. That should import your current settings fully and hopefully replace whatever strange formatting code is in there.

If it’s just this one project that is acting oddly, then you might also check the Project/Text Preferences… panel and either reset the formatting here the same way, or disable this feature entirely with the checkbox at the top.

Thanks, Amber. I’m not sure what part of your advice worked, but now I have added a new ‘chapter’ with the Add button and the text has started wrapping again, and has an indent on the first line.

So whatever part of your magic did the trick, I’m grateful.