Strange behaviour with Samsung Software

I just got asked to run an update for Samsung Support Centre for my new laptop (Easy Support is the Samsung app which updates drivers and stuff). As the laptop prepared to install the update the Scrivener uninstall routine kicked in. I assumed this must have been a mistake on my part so cancelled it.
But the Samsung software refused to install properly so I ran it again - and sure enough the Scrivener uninstall dialog box came up at the same point.

Out of interest I DID click OK this time and the Scrivener uninstall routine ran, removing the app. Samsung then tried to install - but the install failed again. As it did when I tried next time without Scrivener on the screen. I’m sure this is some weirdness within the Samsung app which presumably uses some of the same framework or something. But I thought you’d like to know. I can easily reinstall Scrivener of course and I’ll contact Samsung about their own app.

That’s a weird one! I can’t think of any rational reason for why their updater would uninstall anything you’ve installed, unless it’s got a feature that promises to factory restore your computer—but surely you’ve installed other things as well as Scrivener, so why would it just uninstall that one? I don’t know, but it sounds like it has other problems as well.