Strange fullscreen behaviour

macOS 10.15.3. Scrivener 3.1.5. 15" Late 2017 MacBook Pro, 3.1Ghz, 16Gb/1Tb SSD.

Scrivener running full-screen (native) on MacBook pro screen:

  1. Clicked compile

Didn’t look like the Compile modal had appeared, but then clicking on the Scrivener window no longer worked (surefire sign there’s a hidden modal somewhere). So I swiped through spaces, and there it was torn from the main Scrivener window in a random space.

  1. Clicked compile.

Space jumped back all by itself to the main Scrivener window with another modal asking me for save location.

  1. Saved compile

Scrivener then jumped me back to a completely empty space…

Very confusing behaviour.

This happens for you repeatedly, even after a reboot? I see nothing like it at all on 10.15.3. Both the compile sheet and its subsidiary file save sheet come up in the right location, and no desktop switching occurs.

I’ve not tried rebooting (this is my dev Mac, so I rarely reboot unless there’s a patch). I’ll give that a go. I suspect this may have something to do with external screens: Scrivener was open when I connected (and disconnected) various external screens throughout the day (doing non-Scrivener day-job stuff). When it came to dipping into the novel over lunch, I disconnected from the external 4k displays and that’s when I saw all this strangeness. For the record, no other running applications were affected (VS Code, GitKraken, PhotoShop, Slack, Mail, multiple browsers & terminal windows etc were all fine).

I’ll try testing tomorrow.

It’s a bit unusual to find a sheet within a sheet (which is where it looks like things got a little unhinged), so I’m not surprised you didn’t run into it everywhere else. Some of that stuff is only somewhat “Mac software”, too. Slack is a web app in a box, basically, and Photoshop uses a completely bespoke GUI. Mail is a lot more like Scrivener in terms of UI, but I don’t think it uses sheets much, certainly not to the level of complexity we do.

It’s very doubtful there is a bug in Scrivener’s code, but if you can find a repeatable case with a particular setup, there may be something we can do to avoid the underlying bug (who knows how many system level Full Screen bugs we’ve had to “fix” already, that feature has always been a bit of a nest :laughing:).

Don’t get me started on my hate for Adobe’s custom UI… after all this time they still don’t do windowing properly on macOS (especially full screen). Electron-based apps (like Slack) used to be a pain too, but they’re fine these days.

Anyway! I was unable to replicate the issue today, so I’m just going to blame it on an Apple UI glitch :smiley: