Strange insert behavior on iOS (Version 1.2.2)

I’ve noticed that if I tap in the document window, the cursor is justified to the right. It doesn’t matter if I tap at the end of the most recent line of text. If I start typing, the text appears at the beginning of the next line. If I try to hit backspace, nothing happens. I don’t recall this happening before I got my iPad, but I didn’t really use the app on my iPhone.

I’ve also noticed that this issue appears on the Windows version of Scrivener in the same project. Windows is running the latest version (3.1.something). I’m not sure of the cause of it.

I quite vaguely remember possibly seeing this before, only on the Windows version of a time. It’s not any normal thing, that is sure, and as you’ve found since it doesn’t occur in other projects.

I think what I’d do is look at a page where this happens on your Windows Scrivener, and turn on the Ruler.

With some care and gentle experiment there, you can see where the line start marker actually is, which I suspect might be far to the right where you are seeing it land.

If this is the cause, just re-setting the start point should fix it. You might have some other paragraphs to reset this way if you’ve been working this way.

Since this seems to be affecting both platforms, it must be some kind of formatting. It may not be something you can see or fix on iOS (particularly if there is some kind of table cell weirdness going on). Some things you can try:

  • Does this happen with any newly created document? Just test it, press ⌘N to make a new document, tap done, and then edit the new document. Just bang on the keyboard long enough to have a “paragraph” that is sufficient to trigger the problem.

    If so, then go into Settings.app, scroll down to Scrivener, at the bottom of its settings pane, tap Reset Scrivener, and then toggle the Reset Default Formatting setting. From the multitasking screen, swipe Scrivener up to force it to reload, and go back into your project.

    Again, create a new text item so that it is now using the factory default formatting settings, type a little, and see if the problem is gone. If it is, make this paragraph look the way you want prefer to write, change everything back by hand rather than doing any kind of copy and paste, and set your default again from that. You can discard the test files created now, and you’ll want to go back and apply this corrected formatting to existing text in your project.

  • If newly created documents are fine, then select the text in the affected document and try resetting it to default formatting. That should nuke any weird formatting from the paragraphs and make them act like the text in newly created files.

  • If however it does not, then you might need to use Windows to fix this. The iOS text editor is rather limited in all it can do.

Amber,

Newly created documents do not have this issue. They work as expected. (I.e. tap the line and the cursor goes to the end of the line of text on that line, not to far right justification.)

I reset the document that is having issues to default formatting, the issue persists.

I reset the default formatting in the settings app and still have the same issue. This is the second file for this particular project. The first one started doing some really strange stuff too and I had to create a new project and move everything over.

Other projects appear to be fine and don’t suffer this issue so I’m pinning this on this project.

Okay! Would you be willing to send a copy of this project to me to take a look at? You can tap Edit from the main project screen, select it, and the tap the Share button to send a copy to Files. This will create a date stamped and zipped copy of the project, which you can attach to a private message here.

You could of course also duplicate the project from there as well, and strip everything out of the duplicate other than the item(s) that are causing problems. That would be ideal anyway, as I don’t really need anything other than that, and a project with nothing but that and its trash emptied is smaller to send.

Sent a duplicate with the text file in question in it and nothing else. A nice 106Kb down from around 150MB

Whew, good thing about sending a partial then. :slight_smile: I’ll take a look. Many thanks.

Lots of research… LOL

Okay, this is a relatively simple problem, but it’s made a bit mysterious by how the iOS text editor kind of fumbles with the condition and doesn’t show things how they really are. Basically you’ve got hundreds of spaces on the end of that last paragraph, but it only shows them up to the point of the last line. On Windows it is more obvious because you can see empty lines and dots when Show Invisibles is enabled. So that’s why typing went to the next line, and backspace didn’t seem to do anything. It was doing something, but you’d have to hold it down for an awful long time to see any effect.

At any rate, it’s an easy fix! Just manually position the cursor after the visible part of the text, and press ⇧⌘↓, the shortcut to select from the cursor position to the very bottom of the document, then press backspace. It should all be fine at that point!

2 Likes

I’ve been away from my desktop for a bit and working solely on the iPad, I would have never guessed that was was the issue was. Darn those random spaces… I had tried deleting but it didn’t seem to make a difference.

Thank you!

too much cat walking on the keyboard – or typist falling asleep with head on it :slight_smile:

1 Like

Well, no cats here, and I don’t fall forward when I fall asleep at my desk…

I blame the chipmunks

1 Like