strange invisible page numbers

hi,

  • print a SCR document to pdf file.
  • in pdf file the page numbers are correct
    (visible at the end of all pages Page 1 of 1 (seems a not really centered)
    -print this pdf document to paper
    the page numbers are invisible (disappeared)
    tired this with 2 different printers (Lexmark X 5250 HP 970Cxi)

All ohter elements of the page (titel above are printed correctly)
Ans ideas?

wolfgang

here is the same page with pagenumbers
sorry, I dont know why the pdf in the first post is so big.
wolfgang

Sounds like a printer vs paper format issue.
Best,
Keith

printer vs paper format issue
What does this mean?
wolfgang

I mean it sounds as though the paper is too short to show the page numbers. In 1.02, the page numbers appear at the top and not the bottom, so hopefully this shouldn’t be an issue any more.
Thanks,
Keith

Paper format cant be wrong. Its the common DIN A4 size. Must be a Scrivener issue. Works fine here in Mellel.
Maybe it happens because I used a big font size for printing will check this with a smaller size. Or do I have to set the page number it in the foot note area?

wolfgang
ps: i ´v´sendet you the screenshots by mail. Maybe it died in the spam filter. Asking a favor. Pls delete this images here in the forum (tehy slow downl). It wasnt my intent to upload such big pictures. sorry. thanks in advance

Look, does it work with 1.02? Do you still have the same issue? You shouldn’t, but you don’t mention whether or not you have checked this with 1.02 as I suggested.
Thanks,
Keith

sorry forgot to mention that it hasn´t changed in 1.02.
wolfgang

Then I don’t think I understand, because in 1.02, the page numbers aren’t supposed to be printed at the bottom of the page. They should now appear in the top right-hand corner (provided that you have set the Scrivener Page Layout settings, available via the File menu, to print page numbers), right next to where it shows the title and date. Given that your screenshot shows that the date and title appear, the page numbers should appear as of 1.02, even if they were cut off the bottom in 1.01. Could you please show a different, updated picture of what is happening on 1.02?
Thanks and all the best,
Keith

dont work in 1.03.
The only diffence is that now the page numbers dont appear in the pdf file too.
Scrivener ist really the best writers tool I´v ever seen, but I need that numbers. Sorry…
wolfgang

Keith, pls delete that uploaded images or tell me how can I delete them.

[Brief internet access whilst in Norway:]

What paper size are you using? Is the paper size in Page Setup the same as the one your printer is using?

Paper size is A4. (I m in Europa too.) Both printers are common A4 HP and Lexmark printers. Page Setup is set to A4. Scale is set to 100%. I can send you a screenshot of page setup if you like.
Pls remember. It (page numbering) workes fine in Mellel. (If I have time im gonna che it in other tools)
Worked in an older version of Scribener printing to a pdf file but misses on paper. And it workes fine in the line on the top of the page.
wolfgang

What do you mean by this? In Scrivener 1.02 & 1.03, Scrivener only prints at the top of the page. Nothing gets printed at the bottom of the page. The page numbers get printed in the top right. And of course, you have to have Page Setup set up so that page numbers are checked to print (File > Page Setup > Settings > Scrivener > Text Options, or in Export Draft if printing from there and not directly from the File menu). Just to reiterate, page numbers are no longer printed at the bottom of the page at all. They are now printed next to the header in the top right of the page both in Export Draft and via File > Print.

All the best,
Keith

Do you mean that 1.02 and 1.03 onply prints at the top of the page? The first versions have printed the page numbers on the bottom. Have you canceled this 1.02 and 1.03 ? That would explain it.
I have seted up the page numbers in the pref and they are correctly on the top. But I was talking about the bottom, where most of the readers/lectors are looking for them. You can see that in the screenshots I sent you per mail. Unfortunatly I coulndt delete the wrong one here in the forum.

thanks wolfgaang

That’s exactly what I mean. Page numbers now appear in the top right corner next to the header, and not at the bottom, so it sounds as though it is working properly for you now. The reason for this change is that File > Print now uses the same underlying code as File > Export Draft > Print button. The File > Print option is only meant for a rough print out.
Best,
Keith

When I print a file from Scrivener (not a whole draft export), I get the header at the top right, and the page number. I can see the page number in print/preview, but when I go to actually print it, the page number is so far to the right that it gets cut off the printed page. I have print options set to the correct printer.

Any suggestions?

Thanks.

Michael

What are your margin settings and your paper settings? Do you have any issues when printing from TextEdit with the file name in the top right?
Best,
Keith

Hmmm… Good point. Text Edit does the same thing - the headers and footers begin and end outside the printed area of the page.

I could not find the margin settings in Text Edit. In Scrivener, I have the page set to Letter (US), the margins set left and right to 1," but do you not see a way to alter the margins for the header (including page numbers). In both cases the correct printer is choose.

This does not sound like an exclusively Scrivener problem, sorry to hassle you with it.

Michael

No problem. It would be good to know whether it is a problem specific to your system or a bug with the Apple text system. Page numbering in TextEdit only came in with Tiger (as part of a general view-page-numbering system), and Scrivener uses that system, so if there is a bug somewhere in general then it would certainly appear in Scrivener too. That said, I have never had a problem printing to A4, which is narrower than US Letter…

Best,
Keith