Strange spacing error

I’ve been using Scrivener for a while, and I’m now encountering a very strange spacing situation. My text is justified, but now after every space that I type, Scrivener very harshly justifies everything instead of letting the smaller line just be left-aligned until next line. I’m not exactly sure how to explain this. Before that setting change, Scrivener would keep the appearance of the smaller line (ie. not “complete”) left-aligned until next line change. But now see what happens:

And it must be my fault, because I, uhh, dropped a book on my keyboard, and when I started writing again, Scrivener now started doing this. I have no idea what setting I may have changed without knowing it. I would really appreciate any help to get the situation back to how it was.

Thanks a lot!

Edit. Some more details: After checking the behavior of hidden characters, I realize something strange happens: pressing spacebar actually writes over the “end of line” symbol. That is what happens. So I thought it was just a simple “insert” key problem (my first thought anyway), but it is not the case. There must be some other setting activated…

2nd edit: Some more problems… It changed my small-caps too, that are not very very smalls?!? See:

The text in small caps is set the same size as the roman text… It was not showing like this until this sudden change. What have I done?! Please help me, I gotta finish this thesis pretty soon.

If you don’t need to maintain a variety of font settings and indentations (such as with block quotes), try this:
First, create a snapshot of the document you’re having trouble with (Documents->Snapshots menu) to keep your original safe from irrevocable changes. Then click on the document in the binder and go to the Format->Convert->Formatting to Default Text Style menu. Maybe that will reset whatever font/line/paragraph setting you’ve accidentally engaged.

Good luck!

There actually is quite a lot of formatting I need to maintain, so that is not really an option. But I tried try this on another document (because it does this on EVERY document in my project), and it doesn’t do anything to fix this, unfortunately.

Thanks anyway. This is getting pretty sad.

Sorry, my mistake; I was looking at two different menus and mixed them up.

Sounds like you may need to contact support directly.

While you’re waiting on their response though, do you have the same problem in other projects? If not, you could try copying documents from the binder of your troublesome project to the a new, blank project’s binder and see if that alleviates the issue.

At the very least, you could compose in another project until support gets back to you, then transfer the new stuff back to the original.

Thank you. I followed your advice and contacted them.

I also tried another project, and there is no problem there so it must really be something in my project settings that I changed. No idea what. Hopefully this can be reverted because it is a pretty huge project (for my almost-done-PhD-thesis)… I don’t want to transfer everything in another project.

I appreciate the help! Let’s hope this can be resolved. I’ll post details here after the situation is solved in case someoneone stumbles on this post in the same situation.

Good luck!

If you find that you must transfer to another (presumably blank) project, the menu “File->Import->Scrivener Project” is worth a look. I’m not sure what is transferred, and what isn’t (compile settings? the mysterious formatting setting associated with your current project?) so take that tip with a grain of salt.

Still awaiting answer, and problem is still there. I’m using Scrivener with only left-alignement for now, which at least let me write, but this is not a fix. I’m posting again because I just noticed something else, that could maybe give some more info about the situation. Take the current image:

My cursor was sitting on the second line, and then I pressed ctrl-i so get some italics, and it affected the end-of-paragraph mark on the previous line. It’s like some characters are affected by something when they shouldn’t.

I really fail to see what could be the problem, but no matter what I do, as soon as I press spacebar, it overwrites the end-of-paragraph that should stay there normally. It doesn’t write over anything else, only the end-of-paragraph mark… This is really puzzling.