Strange Split Window outliner behavior

I have a strange (seemingly inexplicable) situation occurring, which is possibly a bug, but also possibly something someone might be able to explain as normal behavior.

I had my window split side by side. The left editor view is the outliner, and I have Navigate→Ouliner Selection Affects→Other Editor ticked.

Back to the problem, as I see it.

I have a folder named Donna (I did a right-click just now to verify, and it is a folder: the Convert to File menu option is available, not the Convert to Folder.) I selected that folder and chose Navigate→Editor→Lock Group View Mode.

Then, with the left editor selected, I then clicked on the folder Donna in the binder, opening it in outline mode in the left editor.

Then, in the outliner in the left editor window, I clicked on a subdocument (opening it in the right editor.)

I put the focus in the right editor and went to work there for a bit and then, forgetting to put the focus back in the left editor, I clicked on Donna in the binder again. This resulted in the outliner view opening in the right editor as well (I’m honestly not sure if I’m surprised by that, but I’d say I’m probably not.)

Here’s where it gets weird:

This first picture shows the outliner with the left editor selected:

This other picture shows the outliner with the right editor selected:

In each case, the view mode icon at the top of the page indicates it is locked, which is no surprise.

But, if you compare the Titles of the documents in each editor to the other, you’ll notice in the right, for some inexplicable reason, the titles are acting like they’re outline numbered, but not the left.

I have no knowledge of how to turn on (or off) such numbering, and I have no idea if there’s a reason each editor would behave differently.

Is this a bug, or just something that has a purpose unclear to me?

This is correct behavior if you have Navigate > Binder Selection Affects = Current. When I use a similar layout, I usually change Binder Selection Affects = Left, to avoid this sort of “surprise”.

Each Outliner has it’s own settings, and your right editor has View > Outliner Options > with Numbers checked, while your left editor does not.

You can also change that setting via the arrow in the top right of the editor header bar:



Thanks, Jim. Everything you said now makes perfect sense the way you explained it.

Much appreciated.

Micah (Heading off to change Navigate→Binder Selection Affects→Current Editor to Navigate→Binder Selection Affects→Left Editor now.)