Strange windowing behaviour (macOS)

1) Full-screen Scrivener. Activate composition mode. You now have the regular full-screen Scrivener window, plus the composition window, in two different spaces (which is what I’d expect).

2) Now, this time don’t full-screen Scrivener before entering composition mode. The composition space is fine, but you can’t get to the original Scrivener window at all (until you exit comp mode).

Related: Global search/replace is unavailable if in state 1). The menu is greyed out. Exiting comp mode makes it available again. This is very confusing if you have comp in one space and full-screen window in another.

Related 2: Try creating a new document when in state 1). Scrivener becomes very confused about what to display in comp mode. Firstly, it appears to highlight TWO documents in the binder (whatever document is directly above the newly created document). When in this state you have to come in and out of comp mode to get it to correctly display the newly created document.

macOS 10.14.1, Scrivener 3.1.2 (whatever latest is, don’t have writing laptop with me today!), 12" 2015 MacBook in Dark Mode,

By default, the Preferences (under “Behaviors”) are set to hide the full screen window, so you should un-check that option to solve (2).

The issue of search/replace being greyed out should already have been fixed for the next update.

If you add a new document, Composition mode won’t show it unless you created it in Composition mode (not in the main window).

All the best,
Keith

Excellent, thank you Keith.