Style Sheet Mayhem

Hi,

I’ve a large project (dissertation, yes, due today), and it has a dozen style sheets. Last night, I went through and made sure each paragraph was in the correct style. This morning, it is mayhem. When I change a style steet, the paragraph belowe is also changing. Please advise.

Thank you,
Sea

Sorry to hear you’re having trouble. But what do you mean by “it has a dozen style sheets”? Do you mean you have a dozen styles, as Scrivener doesn’t have “style sheets” as such?

As for,“when I change a style”, do you mean you modify a style or do you mean that you assign a different style from the list to a paragraph?

Supplementary questions:

  1. Does this mean you have assigned styles to every paragraph in your dissertation, rather than leaving all paragraphs which will have the default as “No Style”? Scrivener’s “No Style” becomes Normal/Body (depending on output format) on compiling.

  2. Can you confirm which version of MacOS you’re using and which version of Scrivener?

Those details make it easier for us to help.

:smiley:

Mark

Thank you for your help.

I have a dozen styles in the project. When I change a paragraph from one style to another, the following paragraph also changes style.

At this point, I do have styles assigend to every paragraph, because leaving it without styles was allowing prior styles to effect the style-free paragraphs.

But even with that, they all seemed to change between saving the project last night and opening it this morning. In truth, I was tired, and they may have been effecting following paragraphs while I was working and I, perhaps, did not notice. This morning, I did see that in action.

I’m on a Studio, Sonoma 14.1.2 and Scrivener 3.3.6 (16305).

Thank you, again!

The paragraph style issues are not all visible in Scrivener (some are). Most are not visible until I compile, then it’s a total mess.

I’m not at my computer for a while… dinner time here with the family. I hope someone else will come along, but can I suggest that you check you haven’t got “Override text…” turned on in your compile format. If you’ve styled everything, you don’t want that turned on.

:smiley:

Mark

Actually, if everything is styled, the “override text formatting” button will be completely ignored in favor of changes (if any) to the Style pane of the Compile Format.

I suspect the root of the problem is the “next style” setting of the base style formatting.

I don’t have the ‘next style’ selected in the styles. And thank you for answering.

Did you write the style changing paragraphs or did you copy them from somewhere else? If the latter, it might be that what looks like a new paragraph is just a new line.

Thank you. I’ve checked all of the line breaks, but that’s not it.

If I understand right, you say the wrong style assignation cascades from one styled paragraph onto the next but which is visible only after compile ?
If so, try compiling with a different compile format, see if that’s where the issue comes from.

Otherwise, assuming that you went through your documents from top to bottom, it is safe to say that you would’ve noticed. (?)

Else, do you select the paragraphs you assign styles to, or do you simply have your cursor anywhere in them (which works just as well) ?
If you select them, make sure you don’t end up with your cursor at the start of the following paragraph.
(To be safe, don’t select them when it is only one – have your cursor anywhere in it, that’ll do. If multiple paragraphs, do a selection across, but don’t select the end. You don’t have to select the whole paragraph from start to finish. If you want to apply a style to multiple consecutive paragraphs, you can select from the middle of the first to the middle of the last.)

Under windows I’ve had a similar issue in the past. I was replacing my carriage returns for a carriage return + something else. Which made all of my styles drop down one paragraph. Perhaps see if your compile format has some similar type of disruptive replacement (?)
Which brings us back to my first advice. Try a different compile format and see.

A suggestion: erase most of the content, replace the text with gibberish, and share a MWE of the project so we can help out more easily and effectively using the project itself.