Styles do not apply

I have a project with chapters and sections. There are thousands of documents that are sections and fifty folders that are chapters. I have used styles to set titles for the documents.

This is the issue: When the documents are all selected (with or without folders being selected) and I select Select Similar Formatting from the Styles Panel to change either the body text or the titles in those documents, only some of them change.

I don’t want to do this by hand, however, that’s the only method which seems to work. What have I missed?

Part of the issue: When the focus is on the Binder, the document in the Editor shows no style for the selected doc. So I don’t always see that there is a style. I still have unsettled docs which should be, however.

Please explain what you have done in more detail.

Are the titles embedded in the documents themselves, with associated Styles?

Are you using the Binder titles, and assigning Styles to them using the appropriate Section Layout?

Something else?

Most of the body text in your manuscript should not have a Style associated with it. Titles can, but aren’t required to.


I am am assembling the text I wish to change as a screening which includes all documents. I am using the styles panel to select all similar styles, first for the titles, then for the body text. I want the body text to have these styles I have defined. When I apply a new style of mine to the selected text, whether it is the title text or the body text, the style does not uniformly apply to the selected text. Some text, body or not, has no style applied as a result. There is some text that is different the body and the titles, but I am not concerned with those until I apply the desired style to the body and the title text I wish to select. I am using the the style drop-down in the Editor to apply styles. My defined styles are in that menu. I don’t know, but I think that means they are embedded. I have defined Section layouts that are the same as the styles, but I am not using them, nor am I using Section styles.

“Screening” should be “Scrivening”

Damn Auto-correct :smiley:

As I said, most of the body text should not have a style defined.

As a general rule, you should accomplish most formatting using the Section Layouts, reserving styles for exceptions. What you are doing is exactly backwards to the way Scrivener is designed to work.

It’s not clear from your description where the titles are coming from. Are you formatting the Binder titles by displaying them in Scrivenings mode? Or are the titles part of the body text of the documents?


The titles are in the body of the document.

I am trying to select all the titles by selecting their styles and changing them and also the same for the body. What is Select Similar Styles (in the Styles panel) for, if not exactly what I am trying to do?

I find the new Sections and Layouts bewildering and have watched the videos for their use many times to little effect. Therefore, I put styles in my documents manually using the brand-new styles system. I am asking for help in making the global changes without the layouts, etc.

Just to make sure we’re talking about the same thing here: there are two separate concepts in Version 3.

Formatting — is how the text looks: size / paragraph spacing / ruler / bold / italics etc etc.

Styles — are a particular combination of formats, which are specially marked in the text, so they can be grouped together.

Two paragraphs can be formatted identically and look identical, while one of them has a style and the other doesn’t. If you remove a single word or a paragraph formatted in italics then that doesn’t affect the other words in italics in the text. But if you change a paragraph style from italics to bold, then every single paragraph with that style will reflect the change.

My guess is that some of your headings have the right format (they’re two sizes bigger, in bold, etc), but they’re not marked as being in the right style, so they’re not being picked up by the ‘Select Similar Formatting’ command.

You can tell the difference by putting your cursor in a selection of text you know has a style — both Select All Style and Select Similar Formatting will highlight all the paragraphs of that style. But if you highlight an example of the text which looks the same, but which doesn’t have the style attached, both All… and …Similar… will ignore the real styled text.

So, what you need to do, is to highlight one of these ‘unstyled’ headings and choose Select Similar Formatting — this will pick up the ones that aren’t already styled — and then apply the correct style to them in the normal way. You’ll have to do it for each heading, but it’s a fairly quick process.

When you’ve done all the headings, then click in your ‘body text’ paragraph, click ‘select Similar formatting’ and change them all to ‘No Style’ (cmd-opt-0). As Kath says, you don’t need a separate body text style — it can complicate compilation later on. When you’ve changed them all to the default ‘No Style’, then you change the format for these default paragraphs in Preferences > Editing > Formatting and converting the documents to the default formatting. Ask if you’re not sure about this part of the process.

There may be other reasons for what you’re finding, but the above steps are the first thing I’d try.


So, what you need to do, is to highlight one of these ‘unstyled’ headings and choose Select Similar Formatting — this will pick up the ones that aren’t already styled — and then apply the correct style to them in the normal way. You’ll have to do it for each heading, but it’s a fairly quick process.

I have done the above and it does not change all the selected text, as I have said previously. That’s the issue. I am trying to isolate them so I don’t have to change 5100+ items by hand. This will allow me to change the unstyled text as it will then stand out.

I’ll re-state the problem:

I am trying to apply styles using the new styles system KB mentions in his blog during he run-up to Scrivener 3.

If I have this:

Title in the body of the doc (in, say Georgia Bold)

Body of the doc. (in, say Georgia)

I want to change it to this:

Title in the body of the doc (in, say Helvetica Bold)

Body of the doc. (in, say Helvetica)

To do this, I choose the Styles Panel and use Select Similar Formatting to change first the titles and then the body, separately.

In so doing, only some of the titles I have selected and some of the body text I have selected change. I expect all selected text to change.

Help me change all I have selected.

The process I have outlined definitely works so that probably means that we’re talking a little bit at cross purposes.

What I suggest you do is take a copy of the project and cut it down to a couple of documents — obviously those where there are examples of the problem you’re seeing. Make sure you anonymise the copy — delete the front matter etc and remove any compilation formats where your name may appear.

Then zip it up and post in on here — that way we’ll be able to see quickly if there’s a problem and what the solution is.


Just checking - Do you have Scrivener fully updated? I experienced a similar problem with styles, but it was fixed in 3.0.2.

Edit: Thread for reference: … =3&t=49572

“No Style” has got to be one of the most confusing developments in Scrivener 3. Every other word processor I’ve ever used with any kind of styling has a base “Normal” or “Body” style as a default. I appreciate the effort to be innovative but it seems it’s just befuddling people (including me).

1 Like

Ah… Ancient Computer User here. When Word first introduced the concept of Styles way back in the 70’s? 80’s? it was the most confusing thing I ever ran into. Scrivener is much more intuitive to me; nothing has a “style” unless I tell it to have a “style”. :smiley:

The reason for this is Scrivener’s intended usage. Scrivener did not shine when I tried to use it as a “What you see is what you get” word processor. I tried this when I first switched to Scrivener from Word, and I was almost as miserable as you are now :slight_smile: . I had a devil of a time when it came time to compile a document for both a) Web display, and b) a fully-formatted PDF for an accompanying handout.

By design, formatting in Scrivener takes place as much as possible in the compiler. That’s how I have ONE primary text, and can format it easily for generic ePub for upload to services like Kobo, Nook, and iTunes, a specialised Kindle format, a simple old-fashioned Word .doc for Smashwords, and a fully-formatted book interior PDF for CreateSpace. Formatting happens after writing, not before.

I suggest you don’t put titles inside your documents, nor sub-titles, nor sub-sub-titles. Instead, I suggest you break your documents into smaller pieces, nest them in the Binder, and name each document with the (sub)(sub) title you currently put into the text. When you compile, you may then format those titles as you choose, hierarchically if that makes sense for your overall project. Only use styles for either a) formatting within paragraphs (italics, bold, etc,) or b) special paragraphs such as block quotes. When it comes time to compile, you may (and probably will!) override ALL such things as fonts, paragraph spacing, indenting, etc. for each style, the document titles and for the “no style” body text. Think of “styles” not as styles as Word uses them, but just a way of denoting to the compiler, later, that it needs to handle this chunk of text differently.

Currently I use a monospaced font in the editor for my default text that by design makes every typo as painfully clear as typography can make it. In my compiler formats, that gets changed to various other fonts (Courier Prime for distribution to beta readers as ancient as I, Times New Roman for submission to less antiquated editors,… Baskerville for my CreateSpace PDFs). I also use line and paragraph spacing in the editor that are quite different from my output formats, again because, in the editor, I want to make it as easy as possible for me to read on-screen and to find my paragraph breaks.

In short, I suggest you view formatting in the editor as that formatting which is comfortable for you WHEN WRITING, and also contains enough information for the compiler, later, to format your document for distribution. It is VERY much a two-step process by design, and trying to do it all in the editor only gave me grief and frustration.

Hope this helps.

I understand perfectly well how compiling works. However, I’m pulling in material from dozens of different sources and a, just looking for a simple way to give it all the same appearance while I work with it.

I apologise for underestimating your level of understanding. Have you tried selecting the documents that you want to have uniform formatting, then using the the Documents > Convert > Text to Default Formatting command? There is a detailed explanation in the Scriv 3 manual in section 15.4.5. If this is irrelevant to your difficulty, again I apologise.

… and the default formatting is usually (always?) the one you select in Preferences?

Here’s the thing that’s throwing me for a loop, and forgive me if I failed to read the thread carefully enough to see the answer to this, but… If you’re using the new styles system in Scrivener 3, and you want to define what that style looks like in the editor, can’t you just format a title the way you want it to look, and then highlight it and select Format->Styles->Redefine Style from Selection…? When you redefine a style’s formatting that way, all text with that style is changed to match the new style definition.

Lunk, yes, the default formatting is the default formatting set in Scrivener Preferences, unless you set a project-specific default formatting in project settings.

No other word processor does what Scrivener does.

One issue with a default “Normal” style is what happens when you then want to change the output formatting with the Compile command. You’d have to define a new “Normal” style for each Compile format. You’d also completely break Scrivener’s existing tools for maintaining and applying “default” text formatting, and would thoroughly befuddle the existing users who depend on them.

Scrivener’s approach to Styles is discussed in detail in Section 15.5 of the manual.


This is a great and clear description of how styles and Compile work together in Scrivener, and wonderful advice for new users coming across this thread.