Styles not being honored in compile

I’ve used styles throughout my book. The FirstPara style doesn’t indent but the Body style does indent. On screen in the editor this all appears OK. Each section begins with FirstPara style and then subsequent paragraphs are Body style and are indented.

What happens after compiling is that on the 2nd paragraph (which is Body style and should be indented) it comes out not indented i.e. same as FirstPara. But then all subsequent paragraphs come out correctly as Body style.

The same thing happens after I’ve used another style. So if I use a Quote style and follow it with a Body style the first paragraph after the Quote doesn’t indent but subsequent ones do.

Am I doing something wrong or is this a bug?

Answering my own question. I found a Compile option on the Styles page “Flatten first indent”. I unchecked this for the Body style and it worked.

The first thing is, you are making your life difficult by assigning a body style to most of your text. You should set up the default style in Options, which will appear as “No Style” in your editor but will become the Body style on compiling. Then you should ensure that your FirstPara style is set to be followed by “No style”. At the moment, you seem to have set FirstPara to be followed by Body style, but Body style is being followed by “No Style” as defined in options.

Actually, you can use “No style” throughout your text with the indent and then set the compiler to remove the indent on paragraphs following headers, empty lines, page breaks, etc.

That said, I use the FirstPara > No Style method as above, because I use my own standard compile format which opens in my WP (Nisus Writer Pro, Mac only … I don’t use Word, but I guess you can do this in Word) where I use a macro to set things like font for different destinations, and then check spelling and make any other changes to section/page breaks as necessary. I use First Para so that those paragraphs have an assigned style which the macro doesn’t turn back into indented “Normal” (Body style in Nisus Writer Pro terms).

Hope that helps.



Topic moved to beta forum, as it pertains to the beta version. – Katherine