Styles shortcuts all messed up (again)

My style shortcuts are completely messed up again. Using them the same as ever, suddenly the shortcut I’ve been using for months produces a completely differently formatted text. The style itself works, if I click on it manually in the drop-down menu, but the shortcut suddenly does its own thing. I have tried deleting and reinstating each style. Doesn’t make any difference - it still chooses its own formatting for that shortcut. I have tried importing styles from a project where it is working properly. That worked for a few hours yesterday, then they all went haywire again. Now importing styles has no effect at all. The same styles (which I really want in all my projects) work absolutely fine in one project, but not in my current project. I have checked all the attributes, and they are identical. Has anyone else experienced this?

It would perhaps help to know if you’re on Mac or Windows.



Style shortcuts shouldn’t be too mysterious, are easy to change, and there is no need to delete and re-create them:

  1. First, open the Styles panel with Format ▸ Styles ▸ Show Styles Panel.
  2. The assigned shortcuts will appear to the right of each style that has one.
  3. For any that are incorrect, right-click on the style in the panel, and use the Change Keyboard Shortcut ▸ submenu to pick the one you want.

I have no idea how these could spontaneously change, the only thing I can think of is that you maybe switched projects—each project has its own style setup, including shortcuts. To keep project styles in sync, you can use the Format ▸ Styles ▸ Import Styles... menu command from the project that needs to be updated, and through the file dialogue box that appears, select the project to copy styles from. Details on how this works are documented in §17.5, Copying Stylesheets Between Projects.

1 Like

I wonder if invoking the shortcut key is actually assigning the intended style at all or perhaps assigning some other style instead. Worth checking the format bar after invoking the command to see if the style in question is actually being assigned to the paragraph as a result.

MacOS has its own shortcut system (not to mention any key macro software you might be running). Is it possible you have a shortcut defined in Apple > Keyboard > Keyboard Shortcuts > App Shortcuts that is running interference?

It’s a toggle and so, definitely, it doesn’t always assign the style.

Mac [more characters]

Changing the keyboard shortcut doesn’t work, because it already shows the keyboard shortcut that I want, so there is nothing I want to change it to. The problem is that using the shortcut gives me a bizare set of formatting rather than the formatting of the style.

Switched projects. You mean: I think I am writing my novel, but actually I am working on my village hall project? I don’t think so.

I have tried importing the styles from a functional project. I think I mentioned that. It worked for a while - then they all went haywire again, and it won’t work again.

I am not using Mac shortcuts. The shortcuts were working fine (like for 6 months) and then they weren’t. Plus it only happens in one project. The same shortcuts are fine in my other project.

I thought of the toggle thing - when I had a similar problem back along, I realised I was toggling between ‘style’ and ‘no style’. But it’s not that this time. The shortcut just suddenly produces a different colour, different font, different justification

OK, a test analysis:

Starting with ‘no style’
Using the shortcut is not attributing a style, nor purporting to (it still says ‘No style’ at the top).
HOWEVER it has randomly changed the justification to Centre.

Starting with one of my styles:
Using the shortcut attributed to a different style (which would normally change the style and its attributes)
It is still purporting to be the same style (says so in the bar above)
BUT it changes the attributes - in this case, a different font and centre justification
If I select the correct style from either the drop-down menu or the styles pane (rather than use the shortcut) it works absolutely fine, and all the attributes are correct

This happens with any other style shortcuts - not sure if there is a pattern to it. Some also capitalise the font.

So it looks as if the shortcut keys are NOT changing the style, but are instead just changing some (to me) random attributes of the typing

It’s not assigning any style that I recognise. It seems random. It is still purporting to be the style I intend (the name is at the top) but changes random aspects of its formatting. Using the shortcut again does not toggle it back to No style as it does when functioning correctly. It just stays the same random formatting and continues to show the style name.

It’s not Mac shortcuts. My other projects are working fine.

I am not running any macros that I am aware of - unless I have inadvertently pressed a combination of keys that has created one? If so, it’s only in this project.

I have no way of knowing how to reproduce this on my own. Try this:

  1. Create a new test project from the Blank project template.
  2. Use the aforementioned style import menu command and target the project that is exhibiting this issue.
  3. Type in some test text, and confirm the problem has conveyed to it.

If that works, use File ▸ Back Up ▸ Back Up To... to create a zipped copy of the test project, and attach it here so we can try to reproduce this on our end.

What an interesting puzzle!

We might work this out in a Zoom session in twenty minutes. Or you could be struggling for quite a long time.

zoom me

I have just tried the test project as suggested.

All the shortcuts are working fine, even though the styles were imported from the problematic project.

There are several shortcuts, based on the default ones, but reattributed to styles I actually use (basically different colour fonts).
Opt Cmd 8, Opt Cmd 9 and Opt Cmd 7 are the ones I use most frequently.

It also changes to a Courier font and sometimes capitalises (not seen any pattern to that)

It also changes to a Courier font and sometimes capitalises (not seen any pattern to that)

Would you say that the binder icons in your affected documents are yellowish in tint instead of white?

If so what you’re seeing isn’t random I would wager, but rather you get the same consistent result over and over with the same shortcut, right? It’s predictable, just not what you think the style should be?

In that case, just hit ⌘8 with all of the yellow icon files selected. You’re using screenplay mode.

YESSSSS! You got it, Amber!
(No yellowy binder icons though - it all looks exactly the same.)

But of course it makes perfect sense: a slip of the finger when intending to type shortcut Opt Cmd 8, and instead I just typed Cmd 8. And so it would have stayed, unless or until I happened to make the same slip again, and it toggled back to standard text.

Thank you so much (and no zoom calls required with creepy old internet guys)!


I’m wondering who she’s looking at :smile: