Substitutions involving diacritics / accents

Hi all,

I’ve been trying to set up some Substitutions for words that I write frequently that will fill in diacritics and accents for me. I’ve set this up in Tools–Options–Corrections–Edit Substitutions, and it doesn’t seem to be making the corrections. All of the corrections I’ve set up involve foreign characters; perhaps this is the issue? For example:
Noldeke --> Nöldeke
Surat --> Sūrat
al-A`la --> al-Aʿlā
…and so on.
Has anyone else experienced this issue, or are foreign characters a limitation of the Substitutions capability? If so, does anyone have a suggestion for how I could better use Scrivener to automate this sort of thing?

Just fyi in case this matters, I use Scrivener on two different systems – one computer uses Windows 7, the other runs Ubuntu Linux, where I run Scrivener through Wine. My projects are saved on Dropbox. I understand that certain features won’t work the same way on the Linux machine–completely fine–but this seems like something I should be able to get running on the Windows computer. I’m on the Windows machine right now.

I believe that you are correct, in that Tools > Options > Corrections > Edit Substitutions is the way to do this, in order for the substitutions to happen as one types text in. It works for me, on a Windows 8.1 Pro 64 bit multi-core PC.

My example, that works for me is
Sebastio -> Sebastião

I copy/pasted your examples into Edit Substitutions (one at a time) and they work for me.

Not sure why this isn’t working for you. First thought is, check in Edit Substitutions and make sure that your substitutions are present AND their “On” checkboxes (which activate them) are checked.

Beyond that, be aware that the substitutions are stored in the Windows registry, in not-easily-read-by-humans form, on a Scrivener version by version basis (i.e. those stored for 1.6.1.0 are not known to 1.7.0.6 and vice versa), on each computer you use Scrivener on (i.e. are not known across computers), rather than more globally (i.e. not per user or per project). In short, you have to reenter them for each version of Scrivener, on each computer you use Scrivener on.

Perhaps someday, L&L will move the storage location for these “as you type text in” substitutions to within projects and/or make the substitutions exportable/importable in a convenient manner.

Other tools for accomplishing similar, later in the process, presumably include find/replace, project replace, replace-during-compile… and presumably work off text entered or stored elsewhere than discussed above.

Hope that helps.

Also ensure that “Enable additional substitutions” is checked in the Corrections pane of Options.

Yes, what she said! :slight_smile:

Ah ha, thank you both for your help! I could have sworn I’d tried the “enable additional substitutions” box earlier and it didn’t work, but now that seems to have done the trick! It does seem a bit odd that checking that box would make it work when all the substitutions I’d added were already checked, but I’m not going to look a gift horse in the mouth :wink:

Thanks again!

Glad it’s working!

If you have a lot of specialised substitutions, the single checkbox gives you a simple way to toggle them all on or off without needing to go through each individually when you don’t want them for a project.

Ah of course – that makes perfect sense.

Has anyone noticed a renewed problem with this since Scrivener 3’s debut? I’ve used several personalized substitutions but have tried to create one today for Mere → Mère and it will not work. The enable box is checked, and as I said, I have others that I use, but this one’s not taking.

I’m not having any issue with that example replacement itself, but there is a bug with replacements that you might be running into, whereby only the replacements created the first time that dialogue is opened during the session take effect. Try going into File ▸ Options... to the Corrections tab, unticking Enable additional substitutions and clicking Apply, and then re-ticking Enable additional substitutions and clicking OK. Does the substitution work in the editor now?

Yes! That did it, thank you! I had just restarted the app before creating it, so I didn’t think that first replacement issue would have been to blame, but toggling that checkmark did fix it. Thank you!

1 Like