suggest completions as you type

In Scrivener3 even though I’ve disabled “suggest completions as you type” I still get those tiny suggestions boxes as I type in composition mode (like on my iPad). What’s the way to turn them completely off?

That is the Mac’s auto-correct feature, rather than anything Scrivener is doing. You might want to switch it off globally (I certainly do), in System Preferences: Keyboard: Text, with Correct spelling automatically at the very top. Scrivener also has a local override to the global setting, in the Corrections pane—again at the very top of the list.