[Suggestion][LH3090|LH3091] In Script Mode, the script element highlight can't be seen with black BG

Windows 10 Home 64bit, Build 17134

If the background color of the Editor is changed to black, you cannot see the text-format-context-popup-menu-highlight for Scriptwriting mode when you press “ENTER.”

How to produce bug:
Overview 1: First we will change the Editor background and text colors in the Options menu.

  1. Go to File > Options > Appearance > General Tab > Colors > Editor Drop-Down > Editor.
  2. Change the Editor color to pure black.
  3. Change the Text color above Editor color to a pure white(or any light color, so we can see the text)
  4. Click Apply at the bottom right corner, then exit Options.
    Overview 2: Now we will put a Text Document into Scriptwriting mode.
  5. Create a new Text Document or select any existing one from the Binder tree.
  6. Go to Format > Scriptwriting > Select any of the preset Script Modes(I’m using the default Screenplay)
  7. Now you should have that Text Document in Script Mode.
    Overview 3: Finally we test out that bug.
  8. Press the “ENTER” key once or twice until the context menu popups with the various text formatting options.
  9. You will notice that using a pure black color for the background in Editor, there is no highlight for the context menu; which makes it difficult to make selections with the arrow keys, you would have to guess which text formatting option is currently being selected based on how many times you press the arrow keys. Normally with a white background and black text, there is a grey highlight for the context menu,

Side Note 1: You can hover your mouse cursor over this context menu, and there’s a faint blue highlight that can be seen, and it’s even more noticeable if the cursor is over the current selection in the context menu.

Side Note 2: If you set the Binder tree background to pure black, you will only see the faint blue selection highlight similar to Side Note 1 when you select or hover over with your mouse cursor. But, once you select off the Binder tree(like working in the inspector), the highlight will disappear. Normally, with a white background, the a gray highlight would still be preset over the item in the Binder tree.

Side Note 3: Also within Composition Mode, the black highlight for the Script Mode popup context menu is very hard to see with the almost black background color.

In conclusion: thoughts, and opinion: Perhaps there are other areas that are not fully compatible with changing the appearance of a background color to pure black within scrivener. In my opinion, a pre-configured black theme for scrivener would be highly valued. Currently, while changing single elements is very powerful: pure black has problems as mentioned up; also, I have no idea what some of those listings in options > appearance > color even correlate to within scrivener. “Text” and “Background” are easy enough, but for vague listings, I don’t know exactly what I am changing and where to find them, to check if the color is to my liking; and whether they should be lighter or darker in contrast to something else. And these color options are only limited to certain areas, not the whole of scrivener. It could be argued that I should just use Composition Mode because it’s already configured all dark, but I do not like minimalist or distraction free modes. I am the kind of person who wants every single detail in front of me, and I even think that 2 split Editor is not enough(I’m thinking at least 4). :smiley:

Thanks for all the hard work Dev-Team!

Thanks! These have been filed. As for your final thoughts, I have marked this post as a suggestion so that we can look at it in the future.

Also, if you are hoping for four editors, you may want to try out copyholders, a new feature that allows each editor (1 normally, 2 in split editor) to have an additional document loaded for comparison. Simply right click a document in the binder and select Open > In Copyholder

Dear Bryan,
The copyholder feature is amazing; I cannot believe my wish had been granted so quickly!

Thank you so much for bringing it to my attention! :smiley:


You’re very welcome!