Suggestions and possible mini-bug with comments/footnotes

Firstly, huge congrats to the Scrivener team on getting Windows 3.0 out! Very exciting.

I use Scrivener for academic projects, and have plenty of comments (in-text, so ‘annotations’ I suppose) and footnotes (again, in-text) throughout my documents. In 3.0.1.0:

  • Highlighting of comment/footnote text is too ‘tall’ (see image). For in-text comments, the highlight box goes well below the line the text is on, and for in-text footnotes, the background colour exceeds the highlight box, and the highlight box goes below the line of text.

[attachment=0]highlighting.png[/attachment]

  • When spell-check is turned on, if there is an in-text comment or footnote directly next to a word, then Scrivener things the comment text and the preceding word are part of the same word and are therefore mis-spelled. So if, for example, I had text followed by comment[like this] then Scrivener would think there was one word ‘commentlike’ and mark it as misspelled. This doesn’t make a lot of sense to me, as footnotes will never be preceded by a space, and as far as comments go, it would appear as though there were random additional spaces in your sentence once comments were removed (hope I’m making sense here).

  • Lastly, I can’t get the ‘hide comments’ function to work. I found a post in the forum for the MacOS version (https://forum.literatureandlatte.com/t/comment-highlights-and-links/41023/13) and followed the same directions, but was unable to hide in-text comments and footnotes - even with them included in the ‘markup’ to ‘hide’ per preferences, and even with Text Editing>Hide Markup activated.

These are minor things at the end of the day, but I figured the team would want to know!